p PatchFirst

CVE-2023-45139

CVE-2023-45139 · fonttools XML External Entity Injection (XXE) Vulnerability

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

fontTools is a library for manipulating fonts, written in Python. The subsetting module has a XML External Entity Injection (XXE) vulnerability which allows an attacker to resolve arbitrary entities when a candidate font (OT-SVG fonts), which contains a SVG table, is parsed. This allows attackers to include arbitrary files from the filesystem fontTools is running on or make web requests from the host system. This vulnerability has been patched in version 4.43.0.

CVSS 7.5 · Высокий · EPSS 1,2% · Есть исправление

Опубликовано
Обновлено

Стек: system · python

Затронутые продукты и версии

  • fonttools

    Версии
    • >= 4.28.2, < 4.43.0: Затронуто

    Нет опубликованного исправления

  • fonttools Debian:12

    Версии
    • 4.38.0-1
    Затронутые диапазоны версий
    • ECOSYSTEM: < 4.38.0-1+deb12u1

    Обновитесь до 4.38.0-1+deb12u1

  • fonttools Debian:13

    Затронутые диапазоны версий
    • ECOSYSTEM: < 4.46.0-1

    Обновитесь до 4.46.0-1

  • fonttools Debian:14

    Затронутые диапазоны версий
    • ECOSYSTEM: < 4.46.0-1

    Обновитесь до 4.46.0-1

  • fonttools PyPI

    Версии
    • 4.28.2
    • 4.28.3
    • 4.28.4
    • 4.28.5
    • 4.29.0
    • 4.29.1
    • 4.30.0
    • 4.31.0
    • 4.31.1
    • 4.31.2
    • 4.32.0
    • 4.33.0
    • 4.33.1
    • 4.33.2
    • 4.33.3
    • 4.34.0
    • 4.34.1
    • 4.34.2
    • 4.34.3
    • 4.34.4
    • 4.35.0
    • 4.36.0
    • 4.37.0
    • 4.37.1
    • 4.37.2
    • 4.37.3
    • 4.37.4
    • 4.38.0
    • 4.38.1.dev0
    • 4.39.0
    • 4.39.1
    • 4.39.2
    • 4.39.3
    • 4.39.4
    • 4.40.0
    • 4.41.0
    • 4.41.1
    • 4.42.0
    • 4.42.1
    Затронутые диапазоны версий
    • ECOSYSTEM: ≥ 4.28.2, < 4.43.0

    Обновитесь до 4.43.0

  • fonttools Ubuntu:Pro:22.04:LTS

    Версии
    • 4.23.1-1
    • 4.27.1-1
    • 4.28.3-1
    • 4.28.5-1
    • 4.29.1-1
    • 4.29.1-2build1
    Затронутые диапазоны версий
    • ECOSYSTEM: < 4.29.1-2ubuntu0.1~esm1

    Обновитесь до 4.29.1-2ubuntu0.1~esm1

Первоисточники

Проверьте свой сервер →