CVE-2023-46302
CVE-2023-46302 · Apache Submarine: Fix CVE-2022-1471 SnakeYaml unsafe deserialization
CVSS 9.8 · Критический · EPSS 1,7% · Есть исправление
Затронуты ли вы?
- apache submarineОбновитесь до 0.8.0
- apache-submarine PyPIОбновитесь до 0.8.0
Как узнать установленную версию:
pip show apache-submarineБесплатная проверка покажет рейтинг сервера и подсветит, требует ли внимания apache submarine и остальные программы. Без регистрации; имена серверов и IP-адреса не отправляются. Номера CVE, версии исправлений и рекомендации — в платном мониторинге.
curl -fsSL https://ru.patchfirst.dev/check.sh | shЗдесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
Apache Software Foundation Apache Submarine has a bug when serializing against yaml. The bug is caused by snakeyaml https://nvd.nist.gov/vuln/detail/CVE-2022-1471 . Apache Submarine uses JAXRS to define REST endpoints. In order to handle YAML requests (using application/yaml content-type), it defines a YamlEntityProvider entity provider that will process all incoming YAML requests. In order to unmarshal the request, the readFrom method is invoked, passing the entityStream containing the user-supplied data in `submarine-server/server-core/src/main/java/org/apache/submarine/server/utils/YamlUtils.java`. We have now fixed this issue in the new version by replacing to `jackson-dataformat-yaml`. This issue affects Apache Submarine: from 0.7.0 before 0.8.0. Users are recommended to upgrade to version 0.8.0, which fixes this issue. If using the version smaller than 0.8.0 and not want to upgrade, you can try cherry-pick PR https://github.com/apache/submarine/pull/1054 and rebuild the submart-server image to fix this.
- Опубликовано
- Обновлено
Стек: python
Затронутые продукты и версии
apache submarine
- Версии
- ≥ 0.7.0, < 0.8.0: Затронуто (semver)
Обновитесь до 0.8.0
apache-submarine PyPI
- Версии
- 0.7.0
- 0.8.0.dev0
- Затронутые диапазоны версий
- ECOSYSTEM: ≥ 0.7.0, < 0.8.0
Обновитесь до 0.8.0