CVE-2023-49582
CVE-2023-49582 · Apache Portable Runtime (APR): Unexpected lax shared memory permissions
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
Lax permissions set by the Apache Portable Runtime library on Unix platforms would allow local users read access to named shared memory segments, potentially revealing sensitive application data. This issue does not affect non-Unix platforms, or builds with APR_USE_SHMEM_SHMGET=1 (apr.h) Users are recommended to upgrade to APR version 1.7.5, which fixes this issue.
CVSS 5.5 · Средний · EPSS 0,3% · Есть исправление
- Опубликовано
- Обновлено
Стек: system
Затронутые продукты и версии
apache portable runtime (apr)
- Версии
- ≥ 0.9.0, ≤ 1.7.4: Затронуто (semver)
Нет опубликованного исправления
apr Debian:12
- Версии
- 1.7.2-3
- Затронутые диапазоны версий
- ECOSYSTEM: < 1.7.2-3+deb12u1
Обновитесь до 1.7.2-3+deb12u1
apr Debian:13
- Затронутые диапазоны версий
- ECOSYSTEM: < 1.7.5-1
Обновитесь до 1.7.5-1
apr Debian:14
- Затронутые диапазоны версий
- ECOSYSTEM: < 1.7.5-1
Обновитесь до 1.7.5-1
apr Ubuntu:Pro:14.04:LTS
- Версии
- 1.4.8-1ubuntu1
- 1.4.8-2
- 1.4.8-3
- 1.5.0-1
- 1.5.0-1ubuntu0.1~esm1
- Затронутые диапазоны версий
- ECOSYSTEM: < 1.5.0-1ubuntu0.1~esm2
Обновитесь до 1.5.0-1ubuntu0.1~esm2
apr Ubuntu:Pro:16.04:LTS
- Версии
- 1.5.2-3
- 1.5.2-3ubuntu0.1~esm1
- Затронутые диапазоны версий
- ECOSYSTEM: < 1.5.2-3ubuntu0.1~esm2
Обновитесь до 1.5.2-3ubuntu0.1~esm2
apr Ubuntu:Pro:18.04:LTS
- Версии
- 1.6.2-1
- 1.6.3-1
- 1.6.3-2
- Затронутые диапазоны версий
- ECOSYSTEM: < 1.6.3-2ubuntu0.1~esm1
Обновитесь до 1.6.3-2ubuntu0.1~esm1
apr Ubuntu:20.04:LTS
- Версии
- 1.6.5-1
- 1.6.5-1ubuntu1
- Затронутые диапазоны версий
- ECOSYSTEM: < 1.6.5-1ubuntu1.1
Обновитесь до 1.6.5-1ubuntu1.1
apr Ubuntu:22.04:LTS
- Версии
- 1.7.0-6ubuntu1
- 1.7.0-8
- 1.7.0-8build1
- 1.7.0-8ubuntu0.22.04.1
- Затронутые диапазоны версий
- ECOSYSTEM: < 1.7.0-8ubuntu0.22.04.2
Обновитесь до 1.7.0-8ubuntu0.22.04.2
apr Ubuntu:24.04:LTS
- Версии
- 1.7.2-3
- 1.7.2-3.1build1
- 1.7.2-3.1build2
- Затронутые диапазоны версий
- ECOSYSTEM: < 1.7.2-3.1ubuntu0.1
Обновитесь до 1.7.2-3.1ubuntu0.1