CVE-2023-7080
CVE-2023-7080 · Arbitrary remote code execution within wrangler dev Workers sandbox
CVSS 8.5 · Высокий · EPSS 0,6% · Есть исправление
Затронуты ли вы?
Как узнать установленную версию:
npm ls wranglerБесплатная проверка покажет рейтинг сервера и подсветит, требует ли внимания wrangler и остальные программы. Без регистрации; имена серверов и IP-адреса не отправляются. Номера CVE, версии исправлений и рекомендации — в платном мониторинге.
curl -fsSL https://ru.patchfirst.dev/check.sh | shЗдесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
The V8 inspector intentionally allows arbitrary code execution within the Workers sandbox for debugging. wrangler dev would previously start an inspector server listening on all network interfaces. This would allow an attacker on the local network to connect to the inspector and run arbitrary code. Additionally, the inspector server did not validate Origin/Host headers, granting an attacker that can trick any user on the local network into opening a malicious website the ability to run code. If wrangler dev --remote was being used, an attacker could access production resources if they were bound to the worker. This issue was fixed in wrangler@3.19.0 and wrangler@2.20.2. Whilst wrangler dev's inspector server listens on local interfaces by default as of wrangler@3.16.0, an SSRF vulnerability in miniflare https://github.com/cloudflare/workers-sdk/security/advisories/GHSA-fwvg-2739-22v7 (CVE-2023-7078) allowed access from the local network until wrangler@3.18.0. wrangler@3.19.0 and wrangler@2.20.2 introduced validation for the Origin/Host headers.
- Опубликовано
- Обновлено
Стек: node
Затронутые продукты и версии
wrangler
- Версии
- ≥ 0, ≤ 3.0.0: Затронуто; ≥ 3.19.0: Не затронуто (patch)
- ≥ 0, < 3.19.0: Затронуто; ≥ 3.19.0: Не затронуто (patch)
- ≥ 0, ≤ 2.0.0: Затронуто; ≥ 2.20.2: Не затронуто (patch)
- ≥ 0, < 2.20.2: Затронуто; ≥ 2.20.2: Не затронуто (patch)
Обновитесь до 2.20.2
wrangler npm
- Затронутые диапазоны версий
- SEMVER: ≥ 3.0.0, < 3.19.0
Обновитесь до 3.19.0
wrangler npm
- Затронутые диапазоны версий
- SEMVER: ≥ 2.0.0, < 2.20.2
Обновитесь до 2.20.2
Первоисточники
- https://github.com/cloudflare/workers-sdk/security/advisories/GHSA-f8mp-x433-5wpf
- https://github.com/cloudflare/workers-sdk/issues/4430
- https://github.com/cloudflare/workers-sdk/pull/4437
- https://github.com/cloudflare/workers-sdk/pull/4535
- https://github.com/cloudflare/workers-sdk/pull/4550
- https://nvd.nist.gov/vuln/detail/CVE-2023-7080