p PatchFirst

CVE-2023-7158

CVE-2023-7158 · MicroPython objslice.c slice_indices heap-based overflow

CVSS 7.3 · Высокий · EPSS 1,2%

Затронуты ли вы?

  • micropythonНет опубликованного исправления
  • giac Ubuntu 18.04 LTSНет опубликованного исправления
  • giac Ubuntu 20.04 LTSНет опубликованного исправления
  • giac Ubuntu 22.04 LTSНет опубликованного исправления
  • и ещё 4

Как узнать установленную версию:

dpkg-query -W -f='${source:Package} ${binary:Package} ${Version}\n' | awk '$1=="giac"'

Бесплатная проверка покажет рейтинг сервера и подсветит, требует ли внимания micropython и остальные программы. Без регистрации; имена серверов и IP-адреса не отправляются. Номера CVE, версии исправлений и рекомендации — в платном мониторинге.

curl -fsSL https://ru.patchfirst.dev/check.sh | sh
Проверить сервер бесплатно →

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

A vulnerability was found in MicroPython up to 1.21.0. It has been classified as critical. Affected is the function slice_indices of the file objslice.c. The manipulation leads to heap-based buffer overflow. It is possible to launch the attack remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 1.22.0 is able to address this issue. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-249180.

Опубликовано
Обновлено

Стек: system

Затронутые продукты и версии

  • micropython

    Версии
    • 1.13.0: Затронуто
    • 1.14.0: Затронуто
    • 1.15.0: Затронуто
    • 1.16.0: Затронуто
    • 1.17.0: Затронуто
    • 1.18.0: Затронуто
    Все версии (9)
    • 1.19.0: Затронуто
    • 1.20.0: Затронуто
    • 1.21.0: Затронуто

    Нет опубликованного исправления

  • giac Ubuntu 18.04 LTS

    Версии
    • 1.2.3.57+dfsg1-2build1
    • 1.2.3.57+dfsg1-2build2
    • 1.2.3.57+dfsg1-2build3
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • giac Ubuntu 20.04 LTS

    Версии
    • 1.4.9.69+dfsg1-2build1
    • 1.5.0.85+dfsg1-2
    • 1.5.0.85+dfsg1-3
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • giac Ubuntu 22.04 LTS

    Версии
    • 1.6.0.41+dfsg1-1
    • 1.7.0.39+dfsg2-1build1
    • 1.7.0.39+dfsg2-1build2
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • giac Ubuntu 24.04 LTS

    Версии
    • 1.9.0.35+dfsg2-1.1
    • 1.9.0.59+dfsg2-1
    • 1.9.0.69+dfsg2-1
    • 1.9.0.93+dfsg2-2
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • giac Ubuntu 25.10

    Версии
    • 1.9.0.93+dfsg2-3build1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • giac Ubuntu 26.10

    Версии
    • 1.9.0.93+dfsg2-3build2
    • 1.9.0.93+dfsg2-4
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • giac Ubuntu 26.04 LTS

    Версии
    • 1.9.0.93+dfsg2-3build1
    • 1.9.0.93+dfsg2-3build2
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

Первоисточники

Проверьте свой сервер →