CVE-2024-10975
CVE-2024-10975 · Nomad Vulnerable To Cross-Namespace Volume Creation Abusing CSI Write Permission
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
Nomad Community and Nomad Enterprise ("Nomad") volume specification is vulnerable to arbitrary cross-namespace volume creation through unauthorized Container Storage Interface (CSI) volume writes. This vulnerability, identified as CVE-2024-10975, is fixed in Nomad Community Edition 1.9.2 and Nomad Enterprise 1.9.2, 1.8.7, and 1.7.15.
CVSS 7.7 · Высокий · EPSS 0,4% · Есть исправление
- Опубликовано
- Обновлено
Стек: system
Затронутые продукты и версии
nomad
- Версии
- ≥ 1.3.0, < 1.9.2: Затронуто (semver)
Обновитесь до 1.9.2
nomad enterprise
- Версии
- ≥ 1.3.0, < 1.9.2: Затронуто; ≥ 1.8.7: Не затронуто; ≥ 1.7.15: Не затронуто (semver)
Обновитесь до 1.7.15
nomad Ubuntu:18.04:LTS
- Версии
- 0.4.0+dfsg-1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
nomad Ubuntu:20.04:LTS
- Версии
- 0.8.7+dfsg1-1ubuntu1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления