CVE-2024-12678
CVE-2024-12678 · Nomad Allocations Vulnerable To Privilege Escalation Within A Namespace Using Unredacted Workload Identity Tokens
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
Nomad Community and Nomad Enterprise ("Nomad") allocations are vulnerable to privilege escalation within a namespace through unredacted workload identity tokens. This vulnerability, identified as CVE-2024-12678, is fixed in Nomad Community Edition 1.9.4 and Nomad Enterprise 1.9.4, 1.8.8, and 1.7.16.
CVSS 6.5 · Средний · EPSS 0,5% · Есть исправление
- Опубликовано
- Обновлено
Стек: system
Затронутые продукты и версии
nomad
- Версии
- ≥ 1.4.0, < 1.9.4: Затронуто (semver)
Обновитесь до 1.9.4
nomad enterprise
- Версии
- ≥ 1.4.0, < 1.9.4: Затронуто; ≥ 1.8.8: Не затронуто; ≥ 1.7.16: Не затронуто (semver)
Обновитесь до 1.7.16
nomad Ubuntu:18.04:LTS
- Версии
- 0.4.0+dfsg-1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
nomad Ubuntu:20.04:LTS
- Версии
- 0.8.7+dfsg1-1ubuntu1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления