CVE-2024-1329
CVE-2024-1329 · Nomad Vulnerable to Arbitrary Write Through Symlink Attack
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
HashiCorp Nomad and Nomad Enterprise 1.5.13 up to 1.6.6, and 1.7.3 template renderer is vulnerable to arbitrary file write on the host as the Nomad client user through symlink attacks. This vulnerability, CVE-2024-1329, is fixed in Nomad 1.7.4, 1.6.7, and 1.5.14.
CVSS 7.7 · Высокий · EPSS 0,6%
- Опубликовано
- Обновлено
Стек: system
Затронутые продукты и версии
nomad
- Версии
- ≥ 0, ≤ 1.5.13: Затронуто (semver)
- ≥ 0, ≤ 1.6.6: Затронуто (semver)
- ≥ 0, ≤ 1.7.3: Затронуто (semver)
Нет опубликованного исправления
nomad enterprise
- Версии
- ≥ 0, ≤ 1.5.13: Затронуто (semver)
- ≥ 0, ≤ 1.6.6: Затронуто (semver)
- ≥ 0, ≤ 1.7.3: Затронуто (semver)
Нет опубликованного исправления
nomad Ubuntu:18.04:LTS
- Версии
- 0.4.0+dfsg-1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
nomad Ubuntu:20.04:LTS
- Версии
- 0.8.7+dfsg1-1ubuntu1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления