CVE-2024-23672
CVE-2024-23672 · Apache Tomcat: WebSocket DoS with incomplete closing handshake
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
Denial of Service via incomplete cleanup vulnerability in Apache Tomcat. It was possible for WebSocket clients to keep WebSocket connections open leading to increased resource consumption.This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.0-M16, from 10.1.0-M1 through 10.1.18, from 9.0.0-M1 through 9.0.85, from 8.5.0 through 8.5.98. Older, EOL versions may also be affected. Users are recommended to upgrade to version 11.0.0-M17, 10.1.19, 9.0.86 or 8.5.99 which fix the issue.
CVSS 6.3 · Средний · EPSS 2,3% · Есть исправление
- Опубликовано
- Обновлено
Стек: system
Затронутые продукты и версии
apache tomcat
- Версии
- ≥ 11.0.0-M1, ≤ 11.0.0-M16: Затронуто (semver)
- ≥ 10.1.0-M1, ≤ 10.1.18: Затронуто (semver)
- ≥ 9.0.0-M1, ≤ 9.0.85: Затронуто (semver)
- ≥ 8.5.0, ≤ 8.5.98: Затронуто (semver)
- ≥ 7, < 8.5.0: Неизвестно (semver)
- ≥ 10.0.0-M1, ≤ 10.0.27: Неизвестно (semver)
Нет опубликованного исправления
tomcat10 Debian:12
- Версии
- 10.1.6-1
- 10.1.6-1+deb12u1
- Затронутые диапазоны версий
- ECOSYSTEM: < 10.1.6-1+deb12u2
Обновитесь до 10.1.6-1+deb12u2
tomcat10 Debian:13
- Затронутые диапазоны версий
- ECOSYSTEM: < 10.1.20-1
Обновитесь до 10.1.20-1
tomcat10 Debian:14
- Затронутые диапазоны версий
- ECOSYSTEM: < 10.1.20-1
Обновитесь до 10.1.20-1
tomcat9 Debian:12
- Затронутые диапазоны версий
- ECOSYSTEM: < 9.0.70-2
Обновитесь до 9.0.70-2
tomcat9 Debian:13
- Затронутые диапазоны версий
- ECOSYSTEM: < 9.0.70-2
Обновитесь до 9.0.70-2
tomcat9 Debian:14
- Затронутые диапазоны версий
- ECOSYSTEM: < 9.0.70-2
Обновитесь до 9.0.70-2
tomcat7 Ubuntu:Pro:14.04:LTS
- Версии
- 7.0.42-1
- 7.0.47-1
- 7.0.50-1
- 7.0.52-1
- 7.0.52-1ubuntu0.1
- 7.0.52-1ubuntu0.3
- 7.0.52-1ubuntu0.6
- 7.0.52-1ubuntu0.7
- 7.0.52-1ubuntu0.8
- 7.0.52-1ubuntu0.9
- 7.0.52-1ubuntu0.10
- 7.0.52-1ubuntu0.11
- 7.0.52-1ubuntu0.13
- 7.0.52-1ubuntu0.14
- 7.0.52-1ubuntu0.15
- 7.0.52-1ubuntu0.16
- 7.0.52-1ubuntu0.16+esm1
- 7.0.52-1ubuntu0.16+esm2
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
tomcat8 Ubuntu:Pro:16.04:LTS
- Версии
- 8.0.26-1
- 8.0.28-1
- 8.0.30-1
- 8.0.32-1
- 8.0.32-1ubuntu1
- 8.0.32-1ubuntu1.1
- 8.0.32-1ubuntu1.2
- 8.0.32-1ubuntu1.3
- 8.0.32-1ubuntu1.4
- 8.0.32-1ubuntu1.5
- 8.0.32-1ubuntu1.6
- 8.0.32-1ubuntu1.7
- 8.0.32-1ubuntu1.8
- 8.0.32-1ubuntu1.9
- 8.0.32-1ubuntu1.10
- 8.0.32-1ubuntu1.11
- 8.0.32-1ubuntu1.13
- 8.0.32-1ubuntu1.13+esm1
- 8.0.32-1ubuntu1.13+esm2
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
tomcat7 Ubuntu:Pro:16.04:LTS
- Версии
- 7.0.64-1
- 7.0.68-1
- 7.0.68-1ubuntu0.1
- 7.0.68-1ubuntu0.3
- 7.0.68-1ubuntu0.4
- 7.0.68-1ubuntu0.4+esm1
- 7.0.68-1ubuntu0.4+esm2
- 7.0.68-1ubuntu0.4+esm3
- 7.0.68-1ubuntu0.4+esm4
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
tomcat8 Ubuntu:Pro:18.04:LTS
- Версии
- 8.5.21-1ubuntu1
- 8.5.29-1
- 8.5.30-1
- 8.5.30-1ubuntu1
- 8.5.30-1ubuntu1.2
- 8.5.30-1ubuntu1.3
- 8.5.30-1ubuntu1.4
- 8.5.39-1ubuntu1~18.04.1
- 8.5.39-1ubuntu1~18.04.2
- 8.5.39-1ubuntu1~18.04.3
- 8.5.39-1ubuntu1~18.04.3+esm1
- 8.5.39-1ubuntu1~18.04.3+esm2
- 8.5.39-1ubuntu1~18.04.3+esm3
- 8.5.39-1ubuntu1~18.04.3+esm4
- Затронутые диапазоны версий
- ECOSYSTEM: < 8.5.39-1ubuntu1~18.04.3+esm5
Обновитесь до 8.5.39-1ubuntu1~18.04.3+esm5
tomcat9 Ubuntu:Pro:18.04:LTS
- Версии
- 9.0.16-3~18.04.1
- 9.0.16-3ubuntu0.18.04.1
- 9.0.16-3ubuntu0.18.04.2
- 9.0.16-3ubuntu0.18.04.2+esm1
- 9.0.16-3ubuntu0.18.04.2+esm2
- 9.0.16-3ubuntu0.18.04.2+esm3
- Затронутые диапазоны версий
- ECOSYSTEM: < 9.0.16-3ubuntu0.18.04.2+esm4
Обновитесь до 9.0.16-3ubuntu0.18.04.2+esm4
tomcat9 Ubuntu:20.04:LTS
- Версии
- 9.0.24-1
- 9.0.27-1
- 9.0.31-1
- 9.0.31-1ubuntu0.1
- 9.0.31-1ubuntu0.2
- 9.0.31-1ubuntu0.3
- 9.0.31-1ubuntu0.4
- 9.0.31-1ubuntu0.5
- 9.0.31-1ubuntu0.6
- 9.0.31-1ubuntu0.7
- Затронутые диапазоны версий
- ECOSYSTEM: < 9.0.31-1ubuntu0.8
Обновитесь до 9.0.31-1ubuntu0.8
tomcat9 Ubuntu:Pro:22.04:LTS
- Версии
- 9.0.43-3
- 9.0.54-1
- 9.0.55-1
- 9.0.58-1
- 9.0.58-1ubuntu0.1
- 9.0.58-1ubuntu0.1+esm1
- 9.0.58-1ubuntu0.1+esm2
- 9.0.58-1ubuntu0.1+esm3
- Затронутые диапазоны версий
- ECOSYSTEM: < 9.0.58-1ubuntu0.1+esm4
Обновитесь до 9.0.58-1ubuntu0.1+esm4
tomcat10 Ubuntu:Pro:24.04:LTS
- Версии
- 10.1.10-1
- 10.1.14-1
- 10.1.15-1
- 10.1.16-1
- 10.1.16-1ubuntu0.1~esm1
- Затронутые диапазоны версий
- ECOSYSTEM: < 10.1.16-1ubuntu0.1~esm2
Обновитесь до 10.1.16-1ubuntu0.1~esm2
tomcat9 Ubuntu:Pro:24.04:LTS
- Версии
- 9.0.70-1ubuntu1
- 9.0.70-2
- 9.0.70-2ubuntu0.1
- 9.0.70-2ubuntu0.1+esm1
- Затронутые диапазоны версий
- ECOSYSTEM: < 9.0.70-2ubuntu0.1+esm2
Обновитесь до 9.0.70-2ubuntu0.1+esm2
tomcat9 Ubuntu:25.10
- Версии
- 9.0.70-2ubuntu1.1
- 9.0.70-2ubuntu2
- Затронутые диапазоны версий
- ECOSYSTEM: < 9.0.70-2ubuntu3
Обновитесь до 9.0.70-2ubuntu3
Первоисточники
- https://lists.apache.org/thread/cmpswfx6tj4s7x0nxxosvfqs11lvdx2f
- https://security.netapp.com/advisory/ntap-20240402-0002/
- https://lists.debian.org/debian-lts-announce/2024/04/msg00001.html
- http://www.openwall.com/lists/oss-security/2024/03/13/4
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/736G4GPZWS2DSQO5WKXO3G6OMZKFEK55/
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/3UWIS5MMGYDZBLJYT674ZI5AWFHDZ46B/
- https://nvd.nist.gov/vuln/detail/CVE-2024-23672