p PatchFirst

CVE-2024-24772

CVE-2024-24772 · Apache Superset: Improper Neutralisation of custom SQL on embedded context

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

A guest user could exploit a chart data REST API and send arbitrary SQL statements that on error could leak information from the underlying analytics database.This issue affects Apache Superset: before 3.0.4, from 3.1.0 before 3.1.1. Users are recommended to upgrade to version 3.1.1 or 3.0.4, which fixes the issue.

CVSS 4.3 · Средний · EPSS 1,0% · Есть исправление

Опубликовано
Обновлено

Стек: python

Затронутые продукты и версии

  • apache superset

    Версии
    • ≥ 0, < 3.0.4: Затронуто (semver)
    • ≥ 3.1.0, < 3.1.1: Затронуто (semver)

    Обновитесь до 3.0.4; Обновитесь до 3.1.1

  • apache-superset PyPI

    Версии
    • 0.34.0
    • 0.34.1
    • 0.35.1
    • 0.35.2
    • 0.36.0
    • 0.37.0
    • 0.37.1
    • 0.37.2
    • 0.38.0
    • 0.38.1
    • 1.0.0
    • 1.0.1
    • 1.1.0
    • 1.2.0
    • 1.3.0
    • 1.3.1
    • 1.3.2
    • 1.4.0
    • 1.4.1
    • 1.4.2
    • 1.5.0
    • 1.5.1
    • 1.5.2
    • 1.5.3
    • 2.0.0
    • 2.0.1
    • 2.1.0
    • 2.1.1
    • 2.1.1rc1
    • 2.1.1rc2
    • 2.1.1rc3
    • 2.1.2
    • 2.1.3
    • 3.0.0
    • 3.0.0rc1
    • 3.0.0rc2
    • 3.0.0rc3
    • 3.0.0rc4
    • 3.0.1
    • 3.0.2
    • 3.0.3
    Затронутые диапазоны версий
    • ECOSYSTEM: < 3.0.4

    Обновитесь до 3.0.4

  • apache-superset PyPI

    Версии
    • 3.1.0
    Затронутые диапазоны версий
    • ECOSYSTEM: ≥ 3.1.0, < 3.1.1

    Обновитесь до 3.1.1

  • apache-superset PyPI

    Версии
    • 0.34.0
    • 0.34.1
    • 0.35.1
    • 0.35.2
    • 0.36.0
    • 0.37.0
    • 0.37.1
    • 0.37.2
    • 0.38.0
    • 0.38.1
    • 1.0.0
    • 1.0.1
    • 1.1.0
    • 1.2.0
    • 1.3.0
    • 1.3.1
    • 1.3.2
    • 1.4.0
    • 1.4.1
    • 1.4.2
    • 1.5.0
    • 1.5.1
    • 1.5.2
    • 1.5.3
    • 2.0.0
    • 2.0.1
    • 2.1.0
    • 2.1.1
    • 2.1.1rc1
    • 2.1.1rc2
    • 2.1.1rc3
    • 2.1.2
    • 2.1.3
    • 3.0.0
    • 3.0.0rc1
    • 3.0.0rc2
    • 3.0.0rc3
    • 3.0.0rc4
    • 3.0.1
    • 3.0.2
    • 3.0.3
    • 3.1.0
    Затронутые диапазоны версий
    • ECOSYSTEM: < 3.0.4 ∪ ≥ 3.1.0, < 3.1.1

    Обновитесь до 3.0.4; Обновитесь до 3.1.1

Первоисточники

Проверьте свой сервер →