p PatchFirst

CVE-2024-27083

CVE-2024-27083 · Flask-AppBuilder's OAuth login page subject to Cross Site Scripting (XSS)

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

Flask-AppBuilder is an application development framework, built on top of Flask. A Cross-Site Scripting (XSS) vulnerability has been discovered on the OAuth login page. An attacker could trick a user to follow a specially crafted URL to the OAuth login page. This URL could inject and execute malicious javascript code that would get executed on the user's browser. This issue was introduced on 4.1.4 and patched on 4.2.1.

CVSS 4.3 · Средний · EPSS 0,6% · Есть исправление

Опубликовано
Обновлено

Стек: python

Затронутые продукты и версии

  • flask-appbuilder

    Версии
    • >= 4.1.4, < 4.2.1: Затронуто

    Нет опубликованного исправления

  • flask-appbuilder PyPI

    Версии
    • 4.1.4
    • 4.1.5
    • 4.1.5rc1
    • 4.1.6
    • 4.1.6rc1
    • 4.1.7rc1
    • 4.2.0
    • 4.2.0rc1
    • 4.2.1rc1
    Затронутые диапазоны версий
    • ECOSYSTEM: ≥ 4.1.4, < 4.2.1

    Обновитесь до 4.2.1

Первоисточники

Проверьте свой сервер →