p PatchFirst

CVE-2024-27298

CVE-2024-27298 · Parse Server literalizeRegexPart SQL Injection

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

parse-server is a Parse Server for Node.js / Express. This vulnerability allows SQL injection when Parse Server is configured to use the PostgreSQL database. The vulnerability has been fixed in 6.5.0 and 7.0.0-alpha.20.

CVSS 10.0 · Критический · EPSS 1,0% · Есть исправление

Опубликовано
Обновлено

Стек: node

Затронутые продукты и версии

  • parse-server

    Версии
    • < 6.5.0: Затронуто
    • >= 7.0.0-alpha.1, < 7.0.0-alpha.20: Затронуто

    Нет опубликованного исправления

  • parse-server npm

    Затронутые диапазоны версий
    • SEMVER: < 6.5.0

    Обновитесь до 6.5.0

  • parse-server npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 7.0.0-alpha.1, < 7.0.0-alpha.20

    Обновитесь до 7.0.0-alpha.20

Первоисточники

Проверьте свой сервер →