p PatchFirst

CVE-2024-28188

CVE-2024-28188 · jupyter-scheduler's endpoint is missing authentication

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

Jupyter Scheduler is collection of extensions for programming jobs to run now or run on a schedule. The list of conda environments of `jupyter-scheduler` users maybe be exposed, potentially revealing information about projects that a specific user may be working on. This vulnerability has been patched in version(s) 1.1.6, 1.2.1, 1.8.2 and 2.5.2.

CVSS 5.3 · Средний · EPSS 0,3% · Есть исправление

Опубликовано
Обновлено

Стек: system · python

Затронутые продукты и версии

  • jupyter-scheduler

    Версии
    • >= 1.0.0, <= 1.1.5: Затронуто
    • = 1.2.0: Затронуто
    • >= 1.3.0, <= 1.8.1: Затронуто
    • >= 2.0.0, <= 2.5.1: Затронуто

    Нет опубликованного исправления

  • jupyter-scheduler PyPI

    Версии
    • 1.0.0
    • 1.1.0
    • 1.1.1
    • 1.1.2
    • 1.1.3
    • 1.1.4
    • 1.1.5
    Затронутые диапазоны версий
    • ECOSYSTEM: ≥ 1.0.0, < 1.1.6

    Обновитесь до 1.1.6

  • jupyter-scheduler PyPI

    Версии
    • 1.2.0
    Затронутые диапазоны версий
    • ECOSYSTEM: ≥ 1.2.0, < 1.2.1

    Обновитесь до 1.2.1

  • jupyter-scheduler PyPI

    Версии
    • 1.3.0
    • 1.3.1
    • 1.3.2
    • 1.3.3
    • 1.3.4
    • 1.4.0
    • 1.5.0
    • 1.6.0
    • 1.7.0
    • 1.8.0
    • 1.8.1
    Затронутые диапазоны версий
    • ECOSYSTEM: ≥ 1.3.0, < 1.8.2

    Обновитесь до 1.8.2

  • jupyter-scheduler PyPI

    Версии
    • 2.0.0
    • 2.1.0
    • 2.2.0
    • 2.3.0
    • 2.4.0
    • 2.5.0
    • 2.5.1
    Затронутые диапазоны версий
    • ECOSYSTEM: ≥ 2.0.0, < 2.5.2

    Обновитесь до 2.5.2

  • jupyter-scheduler PyPI

    Версии
    • 1.0.0
    • 1.1.0
    • 1.1.1
    • 1.1.2
    • 1.1.3
    • 1.1.4
    • 1.1.5
    • 1.2.0
    • 1.3.0
    • 1.3.1
    • 1.3.2
    • 1.3.3
    • 1.3.4
    • 1.4.0
    • 1.5.0
    • 1.6.0
    • 1.7.0
    • 1.8.0
    • 1.8.1
    • 2.0.0
    • 2.1.0
    • 2.2.0
    • 2.3.0
    • 2.4.0
    • 2.5.0
    • 2.5.1
    Затронутые диапазоны версий
    • ECOSYSTEM: ≥ 1.0.0, < 1.1.6 ∪ ≥ 1.2.0, < 1.2.1 ∪ ≥ 1.3.0, < 1.8.2 ∪ ≥ 2.0.0, < 2.5.2

    Обновитесь до 1.1.6; Обновитесь до 1.2.1; Обновитесь до 1.8.2; Обновитесь до 2.5.2

  • jupyter-server Ubuntu:22.04:LTS

    Версии
    • 1.2.2-1
    • 1.13.1-1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • jupyter-server Ubuntu:24.04:LTS

    Версии
    • 1.23.3-1
    • 1.23.3-2
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • jupyter-server Ubuntu:25.10

    Версии
    • 2.14.2-5
    • 2.15.0-1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • jupyter-server Ubuntu:26.10

    Версии
    • 2.17.0-1
    • 2.20.0-3
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • jupyter-server Ubuntu:26.04:LTS

    Версии
    • 2.15.0-1
    • 2.17.0-1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

Первоисточники

Проверьте свой сервер →