CVE-2024-28245
CVE-2024-28245 · KaTeX's \includegraphics does not escape filename
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
KaTeX is a JavaScript library for TeX math rendering on the web. KaTeX users who render untrusted mathematical expressions could encounter malicious input using `\includegraphics` that runs arbitrary JavaScript, or generate invalid HTML. Upgrade to KaTeX v0.16.10 to remove this vulnerability.
CVSS 6.3 · Средний · EPSS 0,4% · Есть исправление
- Опубликовано
- Обновлено
Затронутые продукты и версии
katex
- Версии
- >= 0.11.0, < 0.6.10: Затронуто
Нет опубликованного исправления
node-katex Debian:12
- Версии
- 0.16.10+~cs6.1.0-1
- 0.16.10+~cs6.1.0-2
- 0.16.10+~cs6.1.0-3
- 0.16.10+~cs6.1.0-4
- 0.16.10+~cs6.1.0-5
- 0.16.10+~cs6.1.0-6
- 0.16.10+~cs6.1.0-7
- 0.16.10+~cs6.1.0-8
- 0.16.10+~cs6.1.0-9
- 0.16.4+~cs6.1.0-1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
node-katex Debian:13
- Затронутые диапазоны версий
- ECOSYSTEM: < 0.16.10+~cs6.1.0-1
Обновитесь до 0.16.10+~cs6.1.0-1
node-katex Debian:14
- Затронутые диапазоны версий
- ECOSYSTEM: < 0.16.10+~cs6.1.0-1
Обновитесь до 0.16.10+~cs6.1.0-1
katex npm
- Затронутые диапазоны версий
- SEMVER: ≥ 0.11.0, < 0.16.10
Обновитесь до 0.16.10
node-katex Ubuntu:Pro:22.04:LTS
- Версии
- 0.10.2+dfsg-8
- 0.10.2+dfsg-9
- 0.10.2+dfsg-10
- 0.13.11+~cs6.0.0-2
- Затронутые диапазоны версий
- ECOSYSTEM: < 0.13.11+~cs6.0.0-2ubuntu0.1~esm1
Обновитесь до 0.13.11+~cs6.0.0-2ubuntu0.1~esm1