p PatchFirst

CVE-2024-31211

CVE-2024-31211 · Remote Code Execution in `WP_HTML_Token`

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

WordPress is an open publishing platform for the Web. Unserialization of instances of the `WP_HTML_Token` class allows for code execution via its `__destruct()` magic method. This issue was fixed in WordPress 6.4.2 on December 6th, 2023. Versions prior to 6.4.0 are not affected.

CVSS 5.5 · Средний · EPSS 2,8% · Есть исправление

Опубликовано
Обновлено

Стек: system

Затронутые продукты и версии

  • wordpress-develop

    Версии
    • >= 6.4.0 < 6.4.2: Затронуто

    Нет опубликованного исправления

  • wordpress Debian:13

    Затронутые диапазоны версий
    • ECOSYSTEM: < 6.4.2+dfsg1-1

    Обновитесь до 6.4.2+dfsg1-1

  • wordpress Debian:14

    Затронутые диапазоны версий
    • ECOSYSTEM: < 6.4.2+dfsg1-1

    Обновитесь до 6.4.2+dfsg1-1

  • wordpress Ubuntu:16.04:LTS

    Версии
    • 4.3+dfsg-1
    • 4.3.1+dfsg-1
    • 4.4+dfsg-1
    • 4.4.1+dfsg-1
    • 4.4.2+dfsg-1
    • 4.4.2+dfsg-1ubuntu1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • wordpress Ubuntu:18.04:LTS

    Версии
    • 4.8.2+dfsg-2
    • 4.8.3+dfsg-1
    • 4.9.1+dfsg-1
    • 4.9.2+dfsg-1
    • 4.9.4+dfsg-1
    • 4.9.5+dfsg1-1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • wordpress Ubuntu:20.04:LTS

    Версии
    • 5.2.2+dfsg1-1
    • 5.2.4+dfsg1-1
    • 5.3.2+dfsg1-1
    • 5.3.2+dfsg1-1ubuntu1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • wordpress Ubuntu:22.04:LTS

    Версии
    • 5.7.1+dfsg1-2ubuntu1
    • 5.8.1+dfsg1-2ubuntu1
    • 5.8.2+dfsg1-1ubuntu1
    • 5.8.3+dfsg1-1ubuntu1
    • 5.8.3+dfsg1-1ubuntu1.1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

Первоисточники

Проверьте свой сервер →