CVE-2024-32077
CVE-2024-32077 · Apache Airflow: XSS vulnerability in Task Instance Log/Log Details
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
Apache Airflow version 2.9.0 has a vulnerability that allows an authenticated attacker to inject malicious data into the task instance logs. Users are recommended to upgrade to version 2.9.1, which fixes this issue.
CVSS 5.4 · Средний · EPSS 1,6% · Есть исправление
- Опубликовано
- Обновлено
Стек: python
Затронутые продукты и версии
apache airflow
- Версии
- ≥ 2.9.0, < 2.9.1: Затронуто (semver)
Обновитесь до 2.9.1
apache-airflow PyPI
- Версии
- 2.9.0
- 2.9.1rc1
- 2.9.1rc2
- Затронутые диапазоны версий
- ECOSYSTEM: ≥ 2.9.0, < 2.9.1
Обновитесь до 2.9.1
apache-airflow PyPI
- Версии
- 2.9.0b1
- 2.9.0b2
- 2.9.0rc1
- 2.9.0rc2
- 2.9.0rc3
- Затронутые диапазоны версий
- {"events": [{"introduced": "0"}, {"last_affected": "2.9.0-NA"}, {"last_affected": "2.9.0-beta1"}, {"last_affected": "2.9.0-beta2"}, {"last_affected": "2.9.0-rc1"}, {"last_affected": "2.9.0-rc2"}, {"last_affected": "2.9.0-rc3"}], "type": "ECOSYSTEM"}
Нет опубликованного исправления