p PatchFirst

CVE-2024-32474

CVE-2024-32474 · Sentry's superuser cleartext password leaked in logs

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

Sentry is an error tracking and performance monitoring platform. Prior to 24.4.1, when authenticating as a superuser to Sentry with a username and password, the password is leaked as cleartext in logs under the _event_: `auth-index.validate_superuser`. An attacker with access to the log data could use these leaked credentials to login to the Sentry system as superuser. Self-hosted users on affected versions should upgrade to 24.4.1 or later. Users can configure the logging level to exclude logs of the `INFO` level and only generate logs for levels at `WARNING` or more.

CVSS 7.3 · Высокий · EPSS 0,4% · Есть исправление

Опубликовано
Обновлено

Стек: python

Затронутые продукты и версии

  • sentry

    Версии
    • >= 24.3.0, < 24.4.1: Затронуто

    Нет опубликованного исправления

  • sentry PyPI

    Затронутые диапазоны версий
    • ECOSYSTEM: ≥ 24.3.0, < 24.4.1

    Обновитесь до 24.4.1

Первоисточники

Проверьте свой сервер →