p PatchFirst

CVE-2024-37890

CVE-2024-37890 · Denial of service when handling a request with many HTTP headers in ws

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

ws is an open source WebSocket client and server for Node.js. A request with a number of headers exceeding theserver.maxHeadersCount threshold could be used to crash a ws server. The vulnerability was fixed in ws@8.17.1 (e55e510) and backported to ws@7.5.10 (22c2876), ws@6.2.3 (eeb76d3), and ws@5.2.4 (4abd8f6). In vulnerable versions of ws, the issue can be mitigated in the following ways: 1. Reduce the maximum allowed length of the request headers using the --max-http-header-size=size and/or the maxHeaderSize options so that no more headers than the server.maxHeadersCount limit can be sent. 2. Set server.maxHeadersCount to 0 so that no limit is applied.

CVSS 7.5 · Высокий · EPSS 1,4% · Есть исправление

Опубликовано
Обновлено

Стек: system · node

Затронутые продукты и версии

  • ws

    Версии
    • >= 2.1.0, < 5.2.4: Затронуто
    • >= 6.0.0, < 6.2.3: Затронуто
    • >= 7.0.0, < 7.5.10: Затронуто
    • >= 8.0.0, < 8.17.1: Затронуто

    Нет опубликованного исправления

  • node-ws Debian:12

    Версии
    • 8.11.0+~cs13.7.3-1
    • 8.11.0+~cs13.7.3-2
    • 8.18.0+~cs13.7.11-1
    • 8.18.0+~cs14.5.15-1
    • 8.18.1+~cs14.18.2-1
    • 8.19.0+~cs14.19.1-1
    • 8.20.1+~cs14.19.1-1
    • 8.21.0+~cs14.19.1-1
    • 8.21.1+~cs14.19.1-1
    • 8.21.3+~cs14.19.1-1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • node-ws Debian:13

    Затронутые диапазоны версий
    • ECOSYSTEM: < 8.18.0+~cs13.7.11-1

    Обновитесь до 8.18.0+~cs13.7.11-1

  • node-ws Debian:14

    Затронутые диапазоны версий
    • ECOSYSTEM: < 8.18.0+~cs13.7.11-1

    Обновитесь до 8.18.0+~cs13.7.11-1

  • ws npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 2.1.0, < 5.2.4

    Обновитесь до 5.2.4

  • ws npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 6.0.0, < 6.2.3

    Обновитесь до 6.2.3

  • ws npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 7.0.0, < 7.5.10

    Обновитесь до 7.5.10

  • ws npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 8.0.0, < 8.17.1

    Обновитесь до 8.17.1

  • node-ws Ubuntu:16.04:LTS

    Версии
    • 0.7.2+ds1.349b7460-1
    • 1.0.1+ds1.e6ddaae4-1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • node-ws Ubuntu:18.04:LTS

    Версии
    • 1.1.0+ds1.e6ddaae4-3build1
    • 1.1.0+ds1.e6ddaae4-3ubuntu1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • node-ws Ubuntu:20.04:LTS

    Версии
    • 1.1.0+ds1.e6ddaae4-5
    • 7.2.1-2
    • 7.2.1-3
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • node-ws Ubuntu:22.04:LTS

    Версии
    • 7.4.2+~cs18.0.8-2
    • 7.5.5+~cs13.0.13-1
    • 8.5.0+~cs13.3.3-2
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • node-ws Ubuntu:24.04:LTS

    Версии
    • 8.11.0+~cs13.7.3-1
    • 8.11.0+~cs13.7.3-2
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • node-ws Ubuntu:25.10

    Версии
    • 8.18.0+~cs14.5.15-1
    • 8.18.1+~cs14.18.2-1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • node-ws Ubuntu:26.10

    Версии
    • 8.19.0+~cs14.19.1-1
    • 8.20.1+~cs14.19.1-1
    • 8.21.3+~cs14.19.1-1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • node-ws Ubuntu:26.04:LTS

    Версии
    • 8.18.1+~cs14.18.2-1
    • 8.19.0+~cs14.19.1-1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

Первоисточники

Проверьте свой сервер →