p PatchFirst

CVE-2024-39701

CVE-2024-39701 · Directus Incorrectly handles _in` filter

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

Directus is a real-time API and App dashboard for managing SQL database content. Directus >=9.23.0, <=v10.5.3 improperly handles _in, _nin operators. It evaluates empty arrays as valid so expressions like {"role": {"_in": $CURRENT_USER.some_field}} would evaluate to true allowing the request to pass. This results in Broken Access Control because the rule fails to do what it was intended to do: Pass rule if **field** matches any of the **values**. This vulnerability is fixed in 10.6.0.

CVSS 6.3 · Средний · EPSS 0,4% · Есть исправление

Опубликовано
Обновлено

Стек: node

Затронутые продукты и версии

  • directus

    Версии
    • >= 9.23.0, < 10.6.0: Затронуто

    Нет опубликованного исправления

  • directus npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 9.23.0, < 10.6.0

    Обновитесь до 10.6.0

Первоисточники

Проверьте свой сервер →