p PatchFirst

CVE-2024-41675

CVE-2024-41675 · CKAN has a Cross-site Scripting vector in the Datatables view plugin

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

CKAN is an open-source data management system for powering data hubs and data portals. The Datatables view plugin did not properly escape record data coming from the DataStore, leading to a potential XSS vector. Sites running CKAN >= 2.7.0 with the datatables_view plugin activated. This is a plugin included in CKAN core, that not activated by default but it is widely used to preview tabular data. This vulnerability has been fixed in CKAN 2.10.5 and 2.11.0.

CVSS 6.8 · Средний · EPSS 0,4% · Есть исправление

Опубликовано
Обновлено

Стек: python

Затронутые продукты и версии

  • ckan

    Версии
    • >= 2.7.0, < 2.10.5: Затронуто

    Нет опубликованного исправления

  • ckan PyPI

    Версии
    • 2.10.0
    • 2.10.1
    • 2.10.3
    • 2.10.4
    • 2.7.0
    • 2.7.1
    • 2.7.10
    • 2.7.11
    • 2.7.12
    • 2.7.2
    • 2.7.3
    • 2.7.4
    • 2.7.5
    • 2.7.6
    • 2.7.7
    • 2.7.8
    • 2.7.9
    • 2.8.0
    • 2.8.1
    • 2.8.10
    • 2.8.11
    • 2.8.12
    • 2.8.2
    • 2.8.3
    • 2.8.4
    • 2.8.5
    • 2.8.6
    • 2.8.7
    • 2.8.8
    • 2.8.9
    • 2.9.0
    • 2.9.1
    • 2.9.10
    • 2.9.11
    • 2.9.2
    • 2.9.3
    • 2.9.4
    • 2.9.5
    • 2.9.6
    • 2.9.7
    • 2.9.8
    • 2.9.9
    Затронутые диапазоны версий
    • ECOSYSTEM: ≥ 2.7.0, < 2.10.5

    Обновитесь до 2.10.5

Первоисточники

Проверьте свой сервер →