p PatchFirst

CVE-2024-41677

CVE-2024-41677 · Cross-site Scripting (XSS) vulnerability due to improper HTML escaping in qwik

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

Qwik is a performance focused javascript framework. A potential mutation XSS vulnerability exists in Qwik for versions up to but not including 1.6.0. Qwik improperly escapes HTML on server-side rendering. It converts strings according to the rules found in the `render-ssr.ts` file. It sometimes causes the situation that the final DOM tree rendered on browsers is different from what Qwik expects on server-side rendering. This may be leveraged to perform XSS attacks, and a type of the XSS is known as mXSS (mutation XSS). This has been resolved in qwik version 1.6.0 and @builder.io/qwik version 1.7.3. All users are advised to upgrade. There are no known workarounds for this vulnerability.

CVSS 6.3 · Средний · EPSS 0,5% · Есть исправление

Опубликовано
Обновлено

Стек: node

Затронутые продукты и версии

  • qwik

    Версии
    • @builder.io/qwik: < 1.7.3: Затронуто
    • qwik: < 1.6.0: Затронуто

    Нет опубликованного исправления

  • @builder.io/qwik npm

    Затронутые диапазоны версий
    • SEMVER: < 1.7.3

    Обновитесь до 1.7.3

Первоисточники

Проверьте свой сервер →