p PatchFirst

CVE-2024-41937

CVE-2024-41937 · Apache Airflow: Stored XSS Vulnerability on provider link

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

Apache Airflow, versions before 2.10.0, have a vulnerability that allows the developer of a malicious provider to execute a cross-site scripting attack when clicking on a provider documentation link. This would require the provider to be installed on the web server and the user to click the provider link. Users should upgrade to 2.10.0 or later, which fixes this vulnerability.

CVSS 6.1 · Средний · EPSS 1,7% · Есть исправление

Опубликовано
Обновлено

Стек: python

Затронутые продукты и версии

  • apache airflow

    Версии
    • ≥ 0, < 2.10.0: Затронуто (semver)

    Обновитесь до 2.10.0

  • apache-airflow PyPI

    Версии
    • 1.10.0
    • 1.10.1
    • 1.10.10
    • 1.10.10rc1
    • 1.10.10rc2
    • 1.10.10rc3
    • 1.10.10rc4
    • 1.10.10rc5
    • 1.10.11
    • 1.10.11rc1
    • 1.10.11rc2
    • 1.10.12
    • 1.10.12rc1
    • 1.10.12rc2
    • 1.10.12rc3
    • 1.10.12rc4
    • 1.10.13
    • 1.10.13rc1
    • 1.10.14
    • 1.10.14rc1
    • 1.10.14rc2
    • 1.10.14rc3
    • 1.10.14rc4
    • 1.10.15
    • 1.10.15rc1
    • 1.10.1b1
    • 1.10.1rc2
    • 1.10.2
    • 1.10.2b2
    • 1.10.2rc1
    • 1.10.2rc2
    • 1.10.2rc3
    • 1.10.3
    • 1.10.3b1
    • 1.10.3b2
    • 1.10.3rc1
    • 1.10.3rc2
    • 1.10.4
    • 1.10.4b2
    • 1.10.4rc1
    • 1.10.4rc2
    • 1.10.4rc3
    • 1.10.4rc4
    • 1.10.4rc5
    • 1.10.5
    • 1.10.5rc1
    • 1.10.6
    • 1.10.6rc1
    • 1.10.6rc2
    • 1.10.7
    • 1.10.7rc1
    • 1.10.7rc2
    • 1.10.7rc3
    • 1.10.8
    • 1.10.8rc1
    • 1.10.9
    • 1.10.9rc1
    • 1.8.1
    • 1.8.2
    • 1.8.2rc1
    • 1.9.0
    • 2.0.0
    • 2.0.0b1
    • 2.0.0b2
    • 2.0.0b3
    • 2.0.0rc1
    • 2.0.0rc2
    • 2.0.0rc3
    • 2.0.1
    • 2.0.1rc1
    • 2.0.1rc2
    • 2.0.2
    • 2.0.2rc1
    • 2.1.0
    • 2.1.0rc1
    • 2.1.0rc2
    • 2.1.1
    • 2.1.1rc1
    • 2.1.2
    • 2.1.2rc1
    • 2.1.3
    • 2.1.3rc1
    • 2.1.4
    • 2.1.4rc1
    • 2.1.4rc2
    • 2.10.0b1
    • 2.10.0b2
    • 2.10.0rc1
    • 2.2.0
    • 2.2.0b1
    • 2.2.0b2
    • 2.2.0rc1
    • 2.2.1
    • 2.2.1rc1
    • 2.2.1rc2
    • 2.2.2
    • 2.2.2rc1
    • 2.2.2rc2
    • 2.2.3
    • 2.2.3rc1
    • 2.2.3rc2
    • 2.2.4
    • 2.2.4rc1
    • 2.2.5
    • 2.2.5rc1
    • 2.2.5rc2
    • 2.2.5rc3
    • 2.3.0
    • 2.3.0b1
    • 2.3.0rc1
    • 2.3.0rc2
    • 2.3.1
    • 2.3.1rc1
    • 2.3.2
    • 2.3.2rc1
    • 2.3.2rc2
    • 2.3.3
    • 2.3.3rc1
    • 2.3.3rc2
    • 2.3.3rc3
    • 2.3.4
    • 2.3.4rc1
    • 2.4.0
    • 2.4.0b1
    • 2.4.0rc1
    • 2.4.1
    • 2.4.1rc1
    • 2.4.2
    • 2.4.2rc1
    • 2.4.3
    • 2.4.3rc1
    • 2.5.0
    • 2.5.0rc1
    • 2.5.0rc2
    • 2.5.0rc3
    • 2.5.1
    • 2.5.1rc1
    • 2.5.1rc2
    • 2.5.2
    • 2.5.2rc1
    • 2.5.2rc2
    • 2.5.3
    • 2.5.3rc1
    • 2.5.3rc2
    • 2.6.0
    • 2.6.0b1
    • 2.6.0rc1
    • 2.6.0rc2
    • 2.6.0rc3
    • 2.6.0rc4
    • 2.6.0rc5
    • 2.6.1
    • 2.6.1rc1
    • 2.6.1rc2
    • 2.6.1rc3
    • 2.6.2
    • 2.6.2rc1
    • 2.6.2rc2
    • 2.6.3
    • 2.6.3rc1
    • 2.7.0
    • 2.7.0b1
    • 2.7.0rc1
    • 2.7.0rc2
    • 2.7.1
    • 2.7.1rc1
    • 2.7.1rc2
    • 2.7.2
    • 2.7.2rc1
    • 2.7.3
    • 2.7.3rc1
    • 2.8.0
    • 2.8.0b1
    • 2.8.0rc1
    • 2.8.0rc2
    • 2.8.0rc3
    • 2.8.0rc4
    • 2.8.1
    • 2.8.1rc1
    • 2.8.2
    • 2.8.2rc1
    • 2.8.2rc2
    • 2.8.2rc3
    • 2.8.3
    • 2.8.3rc1
    • 2.8.4
    • 2.8.4rc1
    • 2.9.0
    • 2.9.0b1
    • 2.9.0b2
    • 2.9.0rc1
    • 2.9.0rc2
    • 2.9.0rc3
    • 2.9.1
    • 2.9.1rc1
    • 2.9.1rc2
    • 2.9.2
    • 2.9.2rc1
    • 2.9.3
    • 2.9.3rc1
    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.10.0

    Обновитесь до 2.10.0

Первоисточники

Проверьте свой сервер →