CVE-2024-47774
CVE-2024-47774 · GHSL-2024-262: GStreamer has an OOB-read in gst_avi_subtitle_parse_gab2_chunk
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
GStreamer is a library for constructing graphs of media-handling components. An OOB-read vulnerability has been identified in the gst_avi_subtitle_parse_gab2_chunk function within gstavisubtitle.c. The function reads the name_length value directly from the input file without checking it properly. Then, the a condition, does not properly handle cases where name_length is greater than 0xFFFFFFFF - 17, causing an integer overflow. In such scenario, the function attempts to access memory beyond the buffer leading to an OOB-read. This vulnerability is fixed in 1.24.10.
CVSS 5.1 · Средний · EPSS 0,8% · Есть исправление
- Опубликовано
- Обновлено
Стек: system
Затронутые продукты и версии
gstreamer
- Версии
- < 1.24.10: Затронуто
Нет опубликованного исправления
gst-plugins-good1.0 Debian:12
- Версии
- 1.22.0-5
- 1.22.0-5+deb12u1
- Затронутые диапазоны версий
- ECOSYSTEM: < 1.22.0-5+deb12u2
Обновитесь до 1.22.0-5+deb12u2
gst-plugins-good1.0 Debian:13
- Затронутые диапазоны версий
- ECOSYSTEM: < 1.24.10-1
Обновитесь до 1.24.10-1
gst-plugins-good1.0 Debian:14
- Затронутые диапазоны версий
- ECOSYSTEM: < 1.24.10-1
Обновитесь до 1.24.10-1
gst-plugins-good1.0 Ubuntu:Pro:16.04:LTS
- Версии
- 1.6.0-1ubuntu1
- 1.6.1-1ubuntu1
- 1.6.2-1ubuntu1
- 1.7.1-1ubuntu1
- 1.7.2-1ubuntu1
- 1.7.90-1ubuntu1
- 1.7.91-1ubuntu1
- 1.8.0-1ubuntu1
- 1.8.1-1ubuntu0.1
- 1.8.2-1ubuntu0.1
- 1.8.2-1ubuntu0.2
- 1.8.2-1ubuntu0.3
- 1.8.3-1ubuntu0.3
- 1.8.3-1ubuntu0.4
- 1.8.3-1ubuntu0.5
- 1.8.3-1ubuntu0.5+esm1
- 1.8.3-1ubuntu0.5+esm2
- 1.8.3-1ubuntu0.5+esm3
- 1.8.3-1ubuntu0.5+esm4
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
gst-plugins-good0.10 Ubuntu:16.04:LTS
- Версии
- 0.10.31-3+nmu4ubuntu2~gcc5.1
- 0.10.31-3+nmu4ubuntu2.16.04.1
- 0.10.31-3+nmu4ubuntu2.16.04.2
- 0.10.31-3+nmu4ubuntu2.16.04.3
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
gst-plugins-good1.0 Ubuntu:Pro:18.04:LTS
- Версии
- 1.12.3-1ubuntu1
- 1.12.4-1ubuntu1
- 1.13.1-1ubuntu1
- 1.13.91-1ubuntu1
- 1.14.0-1ubuntu1
- 1.14.1-1ubuntu1~ubuntu18.04.1
- 1.14.4-1ubuntu1~ubuntu18.04.1
- 1.14.5-0ubuntu1~18.04.1
- 1.14.5-0ubuntu1~18.04.2
- 1.14.5-0ubuntu1~18.04.3
- 1.14.5-0ubuntu1~18.04.3+esm1
- 1.14.5-0ubuntu1~18.04.3+esm2
- 1.14.5-0ubuntu1~18.04.3+esm3
- 1.14.5-0ubuntu1~18.04.3+esm4
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
gst-plugins-good1.0 Ubuntu:20.04:LTS
- Версии
- 1.16.1-1ubuntu1
- 1.16.2-1ubuntu1
- 1.16.2-1ubuntu2
- 1.16.2-1ubuntu2.1
- 1.16.3-0ubuntu1
- 1.16.3-0ubuntu1.1
- 1.16.3-0ubuntu1.2
- Затронутые диапазоны версий
- ECOSYSTEM: < 1.16.3-0ubuntu1.3
Обновитесь до 1.16.3-0ubuntu1.3
gst-plugins-good1.0 Ubuntu:22.04:LTS
- Версии
- 1.18.5-1ubuntu2
- 1.18.5-1ubuntu3
- 1.20.0-2ubuntu1
- 1.20.1-1ubuntu1
- 1.20.3-0ubuntu1
- 1.20.3-0ubuntu1.1
- Затронутые диапазоны версий
- ECOSYSTEM: < 1.20.3-0ubuntu1.3
Обновитесь до 1.20.3-0ubuntu1.3
gst-plugins-good1.0 Ubuntu:24.04:LTS
- Версии
- 1.22.6-1ubuntu1
- 1.22.6-1ubuntu2
- 1.22.8-3ubuntu1
- 1.22.9-1ubuntu1
- 1.24.0-1ubuntu5
- 1.24.0-1ubuntu7
- 1.24.1-2ubuntu1
- 1.24.2-1ubuntu1
- Затронутые диапазоны версий
- ECOSYSTEM: < 1.24.2-1ubuntu1.1
Обновитесь до 1.24.2-1ubuntu1.1
Первоисточники
- https://securitylab.github.com/advisories/GHSL-2024-262_Gstreamer/
- https://github.com/github/securitylab-vulnerabilities/issues/1826
- https://gitlab.freedesktop.org/gstreamer/gstreamer/-/merge_requests/8043.patch
- https://lists.debian.org/debian-lts-announce/2025/02/msg00035.html
- https://nvd.nist.gov/vuln/detail/CVE-2024-47774