p PatchFirst

CVE-2024-52316

CVE-2024-52316 · Apache Tomcat: Authentication bypass when using Jakarta Authentication API

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

Unchecked Error Condition vulnerability in Apache Tomcat. If Tomcat is configured to use a custom Jakarta Authentication (formerly JASPIC) ServerAuthContext component which may throw an exception during the authentication process without explicitly setting an HTTP status to indicate failure, the authentication may not fail, allowing the user to bypass the authentication process. There are no known Jakarta Authentication components that behave in this way. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.0-M26, from 10.1.0-M1 through 10.1.30, from 9.0.0-M1 through 9.0.95. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.0 though 8.5.100. Other EOL versions may also be affected. Users are recommended to upgrade to version 11.0.0, 10.1.31 or 9.0.96, which fix the issue.

CVSS 9.8 · Критический · EPSS 6,2% · Есть исправление

Опубликовано
Обновлено

Стек: system

Затронутые продукты и версии

  • apache tomcat

    Версии
    • ≥ 11.0.0-M1, ≤ 11.0.0-M26: Затронуто (semver)
    • ≥ 10.1.0-M1, ≤ 10.1.30: Затронуто (semver)
    • ≥ 9.0.0-M1, ≤ 9.0.95: Затронуто (semver)
    • ≥ 8.5.0, ≤ 8.5.100: Затронуто (semver)
    • ≥ 10.0.0-M1, ≤ 10.0.27: Неизвестно (semver)

    Нет опубликованного исправления

  • tomcat10 Debian:12

    Версии
    • 10.1.10-1
    • 10.1.13-1
    • 10.1.14-1
    • 10.1.15-1
    • 10.1.16-1
    • 10.1.20-1
    • 10.1.23-1
    • 10.1.25-1
    • 10.1.25-1~bpo12+1
    • 10.1.25-2
    • 10.1.30-1
    • 10.1.30-1~bpo12+1
    • 10.1.31-1
    • 10.1.33-1
    • 10.1.33-1~bpo12+1
    • 10.1.6-1
    • 10.1.6-1+deb12u1
    • 10.1.6-1+deb12u2
    • 10.1.7-1
    • 10.1.8-1
    • 10.1.9-1
    Затронутые диапазоны версий
    • ECOSYSTEM: < 10.1.34-0+deb12u1

    Обновитесь до 10.1.34-0+deb12u1

  • tomcat10 Debian:13

    Затронутые диапазоны версий
    • ECOSYSTEM: < 10.1.31-1

    Обновитесь до 10.1.31-1

  • tomcat10 Debian:14

    Затронутые диапазоны версий
    • ECOSYSTEM: < 10.1.31-1

    Обновитесь до 10.1.31-1

  • tomcat9 Debian:12

    Затронутые диапазоны версий
    • ECOSYSTEM: < 9.0.70-2

    Обновитесь до 9.0.70-2

  • tomcat9 Debian:13

    Затронутые диапазоны версий
    • ECOSYSTEM: < 9.0.70-2

    Обновитесь до 9.0.70-2

  • tomcat9 Debian:14

    Затронутые диапазоны версий
    • ECOSYSTEM: < 9.0.70-2

    Обновитесь до 9.0.70-2

  • tomcat8 Ubuntu:Pro:16.04:LTS

    Версии
    • 8.0.26-1
    • 8.0.28-1
    • 8.0.30-1
    • 8.0.32-1
    • 8.0.32-1ubuntu1
    • 8.0.32-1ubuntu1.1
    • 8.0.32-1ubuntu1.2
    • 8.0.32-1ubuntu1.3
    • 8.0.32-1ubuntu1.4
    • 8.0.32-1ubuntu1.5
    • 8.0.32-1ubuntu1.6
    • 8.0.32-1ubuntu1.7
    • 8.0.32-1ubuntu1.8
    • 8.0.32-1ubuntu1.9
    • 8.0.32-1ubuntu1.10
    • 8.0.32-1ubuntu1.11
    • 8.0.32-1ubuntu1.13
    • 8.0.32-1ubuntu1.13+esm1
    • 8.0.32-1ubuntu1.13+esm2
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • tomcat8 Ubuntu:Pro:18.04:LTS

    Версии
    • 8.5.21-1ubuntu1
    • 8.5.29-1
    • 8.5.30-1
    • 8.5.30-1ubuntu1
    • 8.5.30-1ubuntu1.2
    • 8.5.30-1ubuntu1.3
    • 8.5.30-1ubuntu1.4
    • 8.5.39-1ubuntu1~18.04.1
    • 8.5.39-1ubuntu1~18.04.2
    • 8.5.39-1ubuntu1~18.04.3
    • 8.5.39-1ubuntu1~18.04.3+esm1
    • 8.5.39-1ubuntu1~18.04.3+esm2
    • 8.5.39-1ubuntu1~18.04.3+esm3
    • 8.5.39-1ubuntu1~18.04.3+esm4
    • 8.5.39-1ubuntu1~18.04.3+esm5
    • 8.5.39-1ubuntu1~18.04.3+esm6
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • tomcat9 Ubuntu:Pro:18.04:LTS

    Версии
    • 9.0.16-3~18.04.1
    • 9.0.16-3ubuntu0.18.04.1
    • 9.0.16-3ubuntu0.18.04.2
    • 9.0.16-3ubuntu0.18.04.2+esm1
    • 9.0.16-3ubuntu0.18.04.2+esm2
    • 9.0.16-3ubuntu0.18.04.2+esm3
    • 9.0.16-3ubuntu0.18.04.2+esm4
    • 9.0.16-3ubuntu0.18.04.2+esm5
    • 9.0.16-3ubuntu0.18.04.2+esm6
    • 9.0.16-3ubuntu0.18.04.2+esm7
    • 9.0.16-3ubuntu0.18.04.2+esm8
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • tomcat9 Ubuntu:Pro:20.04:LTS

    Версии
    • 9.0.24-1
    • 9.0.27-1
    • 9.0.31-1
    • 9.0.31-1ubuntu0.1
    • 9.0.31-1ubuntu0.2
    • 9.0.31-1ubuntu0.3
    • 9.0.31-1ubuntu0.4
    • 9.0.31-1ubuntu0.5
    • 9.0.31-1ubuntu0.6
    • 9.0.31-1ubuntu0.7
    • 9.0.31-1ubuntu0.8
    • 9.0.31-1ubuntu0.9
    • 9.0.31-1ubuntu0.9+esm1
    • 9.0.31-1ubuntu0.9+esm2
    • 9.0.31-1ubuntu0.9+esm3
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • tomcat9 Ubuntu:Pro:22.04:LTS

    Версии
    • 9.0.43-3
    • 9.0.54-1
    • 9.0.55-1
    • 9.0.58-1
    • 9.0.58-1ubuntu0.1
    • 9.0.58-1ubuntu0.1+esm1
    • 9.0.58-1ubuntu0.1+esm2
    • 9.0.58-1ubuntu0.1+esm3
    • 9.0.58-1ubuntu0.1+esm4
    • 9.0.58-1ubuntu0.2
    • 9.0.58-1ubuntu0.2+esm1
    • 9.0.58-1ubuntu0.2+esm2
    • 9.0.58-1ubuntu0.2+esm3
    • 9.0.58-1ubuntu0.2+esm4
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • tomcat10 Ubuntu:Pro:24.04:LTS

    Версии
    • 10.1.10-1
    • 10.1.14-1
    • 10.1.15-1
    • 10.1.16-1
    • 10.1.16-1ubuntu0.1~esm1
    • 10.1.16-1ubuntu0.1~esm2
    Затронутые диапазоны версий
    • ECOSYSTEM: < 10.1.16-1ubuntu0.1~esm3

    Обновитесь до 10.1.16-1ubuntu0.1~esm3

Первоисточники

Проверьте свой сервер →