CVE-2024-52317
CVE-2024-52317 · Apache Tomcat: Request/response mix-up with HTTP/2
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
Incorrect object re-cycling and re-use vulnerability in Apache Tomcat. Incorrect recycling of the request and response used by HTTP/2 requests could lead to request and/or response mix-up between users. This issue affects Apache Tomcat: from 11.0.0-M23 through 11.0.0-M26, from 10.1.27 through 10.1.30, from 9.0.92 through 9.0.95. Users are recommended to upgrade to version 11.0.0, 10.1.31 or 9.0.96, which fixes the issue.
CVSS 6.5 · Средний · EPSS 2,1% · Публичный эксплойт · Есть исправление
- Опубликовано
- Обновлено
Стек: system
Затронутые продукты и версии
apache tomcat
- Версии
- ≥ 11.0.0-M23, ≤ 11.0.0-M26: Затронуто (semver)
- ≥ 10.1.27, ≤ 10.1.30: Затронуто (semver)
- ≥ 9.0.92, ≤ 9.0.95: Затронуто (semver)
Нет опубликованного исправления
tomcat10 Debian:13
- Затронутые диапазоны версий
- ECOSYSTEM: < 10.1.31-1
Обновитесь до 10.1.31-1
tomcat10 Debian:14
- Затронутые диапазоны версий
- ECOSYSTEM: < 10.1.31-1
Обновитесь до 10.1.31-1
tomcat10 Ubuntu:Pro:24.04:LTS
- Версии
- 10.1.10-1
- 10.1.14-1
- 10.1.15-1
- 10.1.16-1
- 10.1.16-1ubuntu0.1~esm1
- 10.1.16-1ubuntu0.1~esm2
- Затронутые диапазоны версий
- ECOSYSTEM: < 10.1.16-1ubuntu0.1~esm3
Обновитесь до 10.1.16-1ubuntu0.1~esm3
tomcat9 Ubuntu:25.10
- Версии
- 9.0.70-2ubuntu1.1
- 9.0.70-2ubuntu2
- 9.0.70-2ubuntu3
- 9.0.95-1ubuntu1
- 9.0.95-1ubuntu1.1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
tomcat9 Ubuntu:26.04:LTS
- Версии
- 9.0.95-1ubuntu1
- 9.0.111-1
- 9.0.115-1
- 9.0.115-1ubuntu0.1
- 9.0.118-1~26.04.1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления