p PatchFirst

CVE-2024-53847

CVE-2024-53847 · Trix vulnerable to Cross-site Scripting on copy & paste

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

The Trix rich text editor, prior to versions 2.1.9 and 1.3.3, is vulnerable to cross-site scripting (XSS) + mutation XSS attacks when pasting malicious code. An attacker could trick a user to copy and paste malicious code that would execute arbitrary JavaScript code within the context of the user's session, potentially leading to unauthorized actions being performed or sensitive information being disclosed. Users should upgrade to Trix editor version 2.1.9 or 1.3.3, which uses DOMPurify to sanitize the pasted content.

CVSS 5.1 · Средний · EPSS 0,5% · Есть исправление

Опубликовано
Обновлено

Стек: node

Затронутые продукты и версии

  • trix

    Версии
    • >= 2.0.0, < 2.1.9: Затронуто
    • >= 1.0.0, < 1.3.3: Затронуто

    Нет опубликованного исправления

  • trix npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 2.0.0, < 2.1.9

    Обновитесь до 2.1.9

  • trix npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 1.0.0, < 1.3.3

    Обновитесь до 1.3.3

Первоисточники

Проверьте свой сервер →