CVE-2024-53983
CVE-2024-53983 · Server-side request forgery in Backstage Scaffolder plugin
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
The Backstage Scaffolder plugin Houses types and utilities for building scaffolder-related modules. A vulnerability is identified in Backstage Scaffolder template functionality where Server-Side Template Injection (SSTI) can be exploited to perform Git config injection. The vulnerability allows an attacker to capture privileged git tokens used by the Backstage Scaffolder plugin. With these tokens, unauthorized access to sensitive resources in git can be achieved. The impact is considered medium severity as the Backstage Threat Model recommends restricting access to adding and editing templates in the Backstage Catalog plugin. The issue has been resolved in versions `v0.4.12`, `v0.5.1` and `v0.6.1` of the `@backstage/plugin-scaffolder-node` package. Users are encouraged to upgrade to this version to mitigate the vulnerability. Users are advised to upgrade. Users unable to upgrade may ensure that templates do not change git config.
CVSS 5.4 · Средний · EPSS 0,4% · Есть исправление
- Опубликовано
- Обновлено
Стек: node
Затронутые продукты и версии
backstage
- Версии
- < 0.4.12: Затронуто
- = 0.5.0: Затронуто
- = 0.6.0: Затронуто
Нет опубликованного исправления
@backstage/plugin-scaffolder-node npm
- Затронутые диапазоны версий
- SEMVER: < 0.4.12
Обновитесь до 0.4.12
@backstage/plugin-scaffolder-node npm
- Версии
- 0.5.0
- Затронутые диапазоны версий
- SEMVER: ≥ 0.5.0, < 0.5.1
Обновитесь до 0.5.1
@backstage/plugin-scaffolder-node npm
- Версии
- 0.6.0
- Затронутые диапазоны версий
- SEMVER: ≥ 0.6.0, < 0.6.1
Обновитесь до 0.6.1