CVE-2024-7055
CVE-2024-7055 · FFmpeg pnmdec.c pnm_decode_frame heap-based overflow
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
A vulnerability was found in FFmpeg up to 7.0.1. It has been classified as critical. This affects the function pnm_decode_frame in the library /libavcodec/pnmdec.c. The manipulation leads to heap-based buffer overflow. It is possible to initiate the attack remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 7.0.2 is able to address this issue. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-273651.
CVSS 6.9 · Средний · EPSS 1,4% · Есть исправление
- Опубликовано
- Обновлено
Стек: system
Затронутые продукты и версии
ffmpeg
- Версии
- 7.0.0: Затронуто
- 7.0.1: Затронуто
Нет опубликованного исправления
ffmpeg Debian:12
- Версии
- 7:5.1.3-1
- 7:5.1.3-2
- 7:5.1.4-0+deb12u1
- 7:5.1.5-0+deb12u1
- Затронутые диапазоны версий
- ECOSYSTEM: < 7:5.1.6-0+deb12u1
Обновитесь до 7:5.1.6-0+deb12u1
ffmpeg Debian:13
- Затронутые диапазоны версий
- ECOSYSTEM: < 7:7.0.2-1
Обновитесь до 7:7.0.2-1
ffmpeg Debian:14
- Затронутые диапазоны версий
- ECOSYSTEM: < 7:7.0.2-1
Обновитесь до 7:7.0.2-1
libav Ubuntu:Pro:14.04:LTS
- Версии
- 6:0.8.7-1ubuntu2
- 6:9.10-1ubuntu1
- 6:9.10-1ubuntu2
- 6:9.10-1ubuntu5
- 6:9.10-1ubuntu6
- 6:9.10-1ubuntu7
- 6:9.11-2ubuntu1
- 6:9.11-2ubuntu2
- 6:9.13-0ubuntu0.14.04.1
- 6:9.14-0ubuntu0.14.04.1
- 6:9.16-0ubuntu0.14.04.1
- 6:9.18-0ubuntu0.14.04.1
- 6:9.20-0ubuntu0.14.04.1
- 6:9.20-0ubuntu0.14.04.1+esm1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
ffmpeg Ubuntu:Pro:22.04:LTS
- Версии
- 7:4.4-6ubuntu5
- 7:4.4.1-2ubuntu1
- 7:4.4.1-3ubuntu1
- 7:4.4.1-3ubuntu2
- 7:4.4.1-3ubuntu3
- 7:4.4.1-3ubuntu5
- 7:4.4.2-0ubuntu0.22.04.1
- 7:4.4.2-0ubuntu0.22.04.1+esm1
- 7:4.4.2-0ubuntu0.22.04.1+esm2
- 7:4.4.2-0ubuntu0.22.04.1+esm3
- 7:4.4.2-0ubuntu0.22.04.1+esm4
- 7:4.4.2-0ubuntu0.22.04.1+esm5
- 7:4.4.2-0ubuntu0.22.04.1+esm6
- 7:4.4.2-0ubuntu0.22.04.1+esm7
- 7:4.4.2-0ubuntu0.22.04.1+esm8
- Затронутые диапазоны версий
- ECOSYSTEM: < 7:4.4.2-0ubuntu0.22.04.1+esm9
Обновитесь до 7:4.4.2-0ubuntu0.22.04.1+esm9
ffmpeg Ubuntu:Pro:24.04:LTS
- Версии
- 7:6.0-6ubuntu1
- 7:6.0-9ubuntu1
- 7:6.1-2ubuntu1
- 7:6.1-3ubuntu1
- 7:6.1-4ubuntu1
- 7:6.1-5ubuntu1
- 7:6.1.1-1ubuntu1
- 7:6.1.1-3ubuntu1
- 7:6.1.1-3ubuntu5
- 7:6.1.1-3ubuntu5+esm1
- 7:6.1.1-3ubuntu5+esm2
- 7:6.1.1-3ubuntu5+esm3
- 7:6.1.1-3ubuntu5+esm4
- Затронутые диапазоны версий
- ECOSYSTEM: < 7:6.1.1-3ubuntu5+esm5
Обновитесь до 7:6.1.1-3ubuntu5+esm5
Первоисточники
- https://vuldb.com/?id.273651
- https://vuldb.com/?ctiid.273651
- https://vuldb.com/?submit.376532
- https://github.com/CookedMelon/ReportCVE/tree/main/FFmpeg/poc3
- https://ffmpeg.org/download.html
- https://ffmpeg.org/
- https://lists.debian.org/debian-lts-announce/2024/10/msg00019.html
- https://nvd.nist.gov/vuln/detail/CVE-2024-7055