p PatchFirst

CVE-2024-7272

CVE-2024-7272 · FFmpeg swresample.c fill_audiodata heap-based overflow

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

A vulnerability, which was classified as critical, was found in FFmpeg up to 5.1.5. This affects the function fill_audiodata of the file /libswresample/swresample.c. The manipulation leads to heap-based buffer overflow. It is possible to initiate the attack remotely. This issue was fixed in version 6.0 by 9903ba28c28ab18dc7b7b6fb8571cc8b5caae1a6 but a backport for 5.1 was forgotten. The exploit has been disclosed to the public and may be used. Upgrading to version 5.1.6 and 6.0 9903ba28c28ab18dc7b7b6fb8571cc8b5caae1a6 is able to address this issue. It is recommended to upgrade the affected component.

CVSS 6.9 · Средний · EPSS 1,2% · Есть исправление

Опубликовано
Обновлено

Стек: system

Затронутые продукты и версии

  • ffmpeg

    Версии
    • 5.1.0: Затронуто
    • 5.1.1: Затронуто
    • 5.1.2: Затронуто
    • 5.1.3: Затронуто
    • 5.1.4: Затронуто
    • 5.1.5: Затронуто

    Нет опубликованного исправления

  • ffmpeg Debian:12

    Версии
    • 7:5.1.3-1
    • 7:5.1.3-2
    • 7:5.1.4-0+deb12u1
    • 7:5.1.5-0+deb12u1
    Затронутые диапазоны версий
    • ECOSYSTEM: < 7:5.1.6-0+deb12u1

    Обновитесь до 7:5.1.6-0+deb12u1

  • ffmpeg Debian:13

    Затронутые диапазоны версий
    • ECOSYSTEM: < 7:6.0-4

    Обновитесь до 7:6.0-4

  • ffmpeg Debian:14

    Затронутые диапазоны версий
    • ECOSYSTEM: < 7:6.0-4

    Обновитесь до 7:6.0-4

Первоисточники

Проверьте свой сервер →