p PatchFirst

CVE-2024-8947

CVE-2024-8947 · MicroPython objarray.c use after free

CVSS 6.3 · Средний · EPSS 1,0% · Есть исправление

Затронуты ли вы?

  • micropythonНет опубликованного исправления
  • micropython Debian 13Обновитесь до 1.24.0+ds-1
  • micropython Debian 14Обновитесь до 1.24.0+ds-1
  • micropython-copy PyPIНет опубликованного исправления
  • и ещё 4

Как узнать установленную версию:

dpkg-query -W -f='${source:Package} ${binary:Package} ${Version}\n' | awk '$1=="micropython"'
pip show micropython-copy

Бесплатная проверка покажет рейтинг сервера и подсветит, требует ли внимания micropython и остальные программы. Без регистрации; имена серверов и IP-адреса не отправляются. Номера CVE, версии исправлений и рекомендации — в платном мониторинге.

curl -fsSL https://ru.patchfirst.dev/check.sh | sh
Проверить сервер бесплатно →

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

A vulnerability was found in MicroPython 1.22.2. It has been declared as critical. Affected by this vulnerability is an unknown functionality of the file py/objarray.c. The manipulation leads to use after free. The attack can be launched remotely. The complexity of an attack is rather high. The exploitation appears to be difficult. Upgrading to version 1.23.0 is able to address this issue. The identifier of the patch is 4bed614e707c0644c06e117f848fa12605c711cd. It is recommended to upgrade the affected component. In micropython objarray component, when a bytes object is resized and copied into itself, it may reference memory that has already been freed.

Опубликовано
Обновлено

Стек: system · python

Затронутые продукты и версии

  • micropython

    Версии
    • 1.22.2: Затронуто

    Нет опубликованного исправления

  • micropython Debian 13

    Затронутые диапазоны версий
    • ECOSYSTEM: < 1.24.0+ds-1

    Обновитесь до 1.24.0+ds-1

  • micropython Debian 14

    Затронутые диапазоны версий
    • ECOSYSTEM: < 1.24.0+ds-1

    Обновитесь до 1.24.0+ds-1

  • micropython-copy PyPI

    Версии
    • 0.0.1
    • 0.0.2
    • 3.3.3-2
    • 3.3.3.post3
    Затронутые диапазоны версий
    • ECOSYSTEM: ≤ 3.3.3.post3

    Нет опубликованного исправления

  • micropython-io PyPI

    Версии
    • 0.0.1
    • 0.0.2
    • 0.0.3
    • 0.1
    Затронутые диапазоны версий
    • ECOSYSTEM: ≤ 0.1

    Нет опубликованного исправления

  • micropython-copy PyPI

    Версии
    • 0.0.1
    • 0.0.2
    • 3.3.3-2
    • 3.3.3.post3
    Затронутые диапазоны версий
    • GIT: < 4bed614e707c0644c06e117f848fa12605c711cd
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • micropython-io PyPI

    Версии
    • 0.0.1
    • 0.0.2
    • 0.0.3
    • 0.1
    • v1.22.0
    • v1.23.0-preview
    Все версии (62)
    • v1.22.0-preview
    • v1.21.0
    • v1.20.0
    • v1.19.1
    • v1.19
    • v1.18
    • v1.17
    • v1.16
    • v1.15
    • v1.14
    • v1.13
    • v1.12
    • v1.11
    • v1.10
    • v1.9.4
    • v1.9.3
    • v1.9.2
    • v1.9.1
    • v1.9
    • v1.8.7
    • v1.8.6
    • v1.8.5
    • v1.8.4
    • v1.8.3
    • v1.8.2
    • v1.8.1
    • v1.8
    • v1.7
    • v1.6
    • v1.5.2
    • v1.5.1
    • v1.5
    • v1.4.6
    • v1.4.5
    • v1.4.4
    • v1.4.3
    • v1.4.2
    • v1.4.1
    • v1.4
    • v1.3.10
    • v1.3.9
    • v1.3.8
    • v1.3.7
    • v1.3.6
    • v1.3.5
    • v1.3.4
    • v1.3.3
    • v1.3.2
    • v1.3.1
    • v1.3
    • v1.2
    • v1.1.1
    • v1.1
    • v1.0.1
    • v1.0
    • v1.0-rc1
    Затронутые диапазоны версий
    • GIT: < 4bed614e707c0644c06e117f848fa12605c711cd
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • micropython Ubuntu Pro 20.04 LTS

    Версии
    • 1.12-1
    Затронутые диапазоны версий
    • ECOSYSTEM: < 1.12-1ubuntu0.1~esm1

    Обновитесь до 1.12-1ubuntu0.1~esm1

  • micropython Ubuntu Pro 22.04 LTS

    Версии
    • 1.17+ds-1ubuntu1
    • 1.17+ds-1.1
    • 1.17+ds-1.1ubuntu2
    Затронутые диапазоны версий
    • ECOSYSTEM: < 1.17+ds-1.1ubuntu2+esm1

    Обновитесь до 1.17+ds-1.1ubuntu2+esm1

  • micropython Ubuntu Pro 24.04 LTS

    Версии
    • 1.19.1+ds-1
    • 1.22.1+ds-1
    • 1.22.1+ds-1build1
    • 1.22.1+ds-1build2
    Затронутые диапазоны версий
    • ECOSYSTEM: < 1.22.1+ds-1ubuntu0.24.04.1~esm1

    Обновитесь до 1.22.1+ds-1ubuntu0.24.04.1~esm1

Первоисточники

Проверьте свой сервер →