CVE-2025-11375
CVE-2025-11375 · Consul's event endpoint is vulnerable to denial of service
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
Consul and Consul Enterprise’s (“Consul”) event endpoint is vulnerable to denial of service (DoS) due to lack of maximum value on the Content Length header. This vulnerability, CVE-2025-11375, is fixed in Consul Community Edition 1.22.0 and Consul Enterprise 1.22.0, 1.21.6, 1.20.8 and 1.18.12.
CVSS 6.5 · Средний · EPSS 0,4% · Есть исправление
- Опубликовано
- Обновлено
Стек: system
Затронутые продукты и версии
consul
- Версии
- ≥ 0, < 1.22.0: Затронуто (semver)
Обновитесь до 1.22.0
consul enterprise
- Версии
- ≥ 0, < 1.22.0: Затронуто; ≥ 1.21.6: Не затронуто; ≥ 1.20.8: Не затронуто; ≥ 1.18.12: Не затронуто (semver)
Обновитесь до 1.18.12
consul Debian:11
- Версии
- 1.10.12+dfsg1-1
- 1.8.7+dfsg1-2
- 1.8.7+dfsg1-3
- 1.8.7+dfsg1-4
- 1.8.7+dfsg1-5
- 1.8.7+dfsg1-6
- 1.9.17+dfsg2-1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
consul Ubuntu:18.04:LTS
- Версии
- 0.6.4~dfsg-3
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
consul Ubuntu:20.04:LTS
- Версии
- 1.0.7~dfsg1-5ubuntu1
- 1.4.4~dfsg1-2ubuntu2
- 1.5.2+dfsg1-6
- 1.5.2+dfsg1-10
- 1.5.2+dfsg1-12
- 1.5.2+dfsg2-14
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
consul Ubuntu:22.04:LTS
- Версии
- 1.7.4+dfsg1-1
- 1.8.7+dfsg1-3
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления