CVE-2025-2173
CVE-2025-2173 · libzvbi conv.c vbi_strndup_iconv_ucs2 uninitialized pointer
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
A vulnerability was found in libzvbi up to 0.2.43. It has been classified as problematic. Affected is the function vbi_strndup_iconv_ucs2 of the file src/conv.c. The manipulation of the argument src_length leads to uninitialized pointer. It is possible to launch the attack remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 0.2.44 is able to address this issue. The patch is identified as 8def647eea27f7fd7ad33ff79c2d6d3e39948dce. It is recommended to upgrade the affected component. The code maintainer was informed beforehand about the issues. She reacted very fast and highly professional.
CVSS 6.9 · Средний · EPSS 0,6% · Есть исправление
- Опубликовано
- Обновлено
Стек: system
Затронутые продукты и версии
libzvbi
- Версии
- 0.2.0: Затронуто
- 0.2.1: Затронуто
- 0.2.2: Затронуто
- 0.2.3: Затронуто
- 0.2.4: Затронуто
- 0.2.5: Затронуто
- 0.2.6: Затронуто
- 0.2.7: Затронуто
- 0.2.8: Затронуто
- 0.2.9: Затронуто
- 0.2.10: Затронуто
- 0.2.11: Затронуто
- 0.2.12: Затронуто
- 0.2.13: Затронуто
- 0.2.14: Затронуто
- 0.2.15: Затронуто
- 0.2.16: Затронуто
- 0.2.17: Затронуто
- 0.2.18: Затронуто
- 0.2.19: Затронуто
- 0.2.20: Затронуто
- 0.2.21: Затронуто
- 0.2.22: Затронуто
- 0.2.23: Затронуто
- 0.2.24: Затронуто
- 0.2.25: Затронуто
- 0.2.26: Затронуто
- 0.2.27: Затронуто
- 0.2.28: Затронуто
- 0.2.29: Затронуто
- 0.2.30: Затронуто
- 0.2.31: Затронуто
- 0.2.32: Затронуто
- 0.2.33: Затронуто
- 0.2.34: Затронуто
- 0.2.35: Затронуто
- 0.2.36: Затронуто
- 0.2.37: Затронуто
- 0.2.38: Затронуто
- 0.2.39: Затронуто
- 0.2.40: Затронуто
- 0.2.41: Затронуто
- 0.2.42: Затронуто
- 0.2.43: Затронуто
Нет опубликованного исправления
zvbi Debian:12
- Версии
- 0.2.41-1
- Затронутые диапазоны версий
- ECOSYSTEM: < 0.2.41-1+deb12u1
Обновитесь до 0.2.41-1+deb12u1
zvbi Debian:13
- Затронутые диапазоны версий
- ECOSYSTEM: < 0.2.44-1
Обновитесь до 0.2.44-1
zvbi Debian:14
- Затронутые диапазоны версий
- ECOSYSTEM: < 0.2.44-1
Обновитесь до 0.2.44-1
zvbi Ubuntu:14.04:LTS
- Версии
- 0.2.33-7
- 0.2.35-2
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
zvbi Ubuntu:Pro:16.04:LTS
- Версии
- 0.2.35-9
- 0.2.35-10
- Затронутые диапазоны версий
- ECOSYSTEM: < 0.2.35-10ubuntu0.1~esm1
Обновитесь до 0.2.35-10ubuntu0.1~esm1
zvbi Ubuntu:Pro:18.04:LTS
- Версии
- 0.2.35-13
- Затронутые диапазоны версий
- ECOSYSTEM: < 0.2.35-13ubuntu0.1~esm1
Обновитесь до 0.2.35-13ubuntu0.1~esm1
zvbi Ubuntu:Pro:20.04:LTS
- Версии
- 0.2.35-16
- 0.2.35-17
- Затронутые диапазоны версий
- ECOSYSTEM: < 0.2.35-17ubuntu0.1~esm1
Обновитесь до 0.2.35-17ubuntu0.1~esm1
zvbi Ubuntu:Pro:22.04:LTS
- Версии
- 0.2.35-18
- 0.2.35-19
- Затронутые диапазоны версий
- ECOSYSTEM: < 0.2.35-19ubuntu0.1~esm1
Обновитесь до 0.2.35-19ubuntu0.1~esm1
zvbi Ubuntu:Pro:24.04:LTS
- Версии
- 0.2.41-2
- 0.2.42-1
- 0.2.42-1.1
- 0.2.42-1.2
- 0.2.42-2
- Затронутые диапазоны версий
- ECOSYSTEM: < 0.2.42-2ubuntu0.24.04.1~esm1
Обновитесь до 0.2.42-2ubuntu0.24.04.1~esm1
Первоисточники
- https://vuldb.com/?id.299202
- https://vuldb.com/?ctiid.299202
- https://vuldb.com/?submit.512798
- https://github.com/zapping-vbi/zvbi/security/advisories/GHSA-g7cg-7gw9-v8cf
- https://github.com/zapping-vbi/zvbi/commit/8def647eea27f7fd7ad33ff79c2d6d3e39948dce
- https://github.com/zapping-vbi/zvbi/releases/tag/v0.2.44
- https://nvd.nist.gov/vuln/detail/CVE-2025-2173