CVE-2025-22153
CVE-2025-22153 · try/except* clauses could allow bypass RestrictedPython via type confusion bug in the CPython interpreter
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
RestrictedPython is a tool that helps to define a subset of the Python language which allows to provide a program input into a trusted environment. Via a type confusion bug in versions of the CPython interpreter starting in 3.11 and prior to 3.13.2 when using `try/except*`, RestrictedPython starting in version 6.0 and prior to version 8.0 could be bypassed. The issue is patched in version 8.0 of RestrictedPython by removing support for `try/except*` clauses. No known workarounds are available.
CVSS 7.9 · Высокий · EPSS 0,4% · Есть исправление
- Опубликовано
- Обновлено
Затронутые продукты и версии
restrictedpython
- Версии
- >= 6.0, < 8.0: Затронуто
Нет опубликованного исправления
restrictedpython Debian:13
- Затронутые диапазоны версий
- ECOSYSTEM: < 8.0-1
Обновитесь до 8.0-1
restrictedpython Debian:14
- Затронутые диапазоны версий
- ECOSYSTEM: < 8.0-1
Обновитесь до 8.0-1
restrictedpython PyPI
- Версии
- 6.0
- 6.1
- 6.2
- 7.0
- 7.0a1.dev0
- 7.0a1.dev1
- 7.0a2.dev0
- 7.1
- 7.2
- 7.2a1.dev0
- 7.3
- 7.4
- Затронутые диапазоны версий
- ECOSYSTEM: ≥ 6.0, < 8.0
Обновитесь до 8.0
restrictedpython Ubuntu:Pro:24.04:LTS
- Версии
- 4.0~b3-3
- 6.2-1
- Затронутые диапазоны версий
- ECOSYSTEM: < 6.2-1ubuntu0.24.04.1~esm1
Обновитесь до 6.2-1ubuntu0.24.04.1~esm1