CVE-2025-23209
CVE-2025-23209 · Potential RCE with a compromised security key in craft/cms
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
Craft is a flexible, user-friendly CMS for creating custom digital experiences on the web and beyond. This is an remote code execution (RCE) vulnerability that affects Craft 4 and 5 installs where your security key has already been compromised. Anyone running an unpatched version of Craft with a compromised security key is affected. This vulnerability has been patched in Craft 5.5.8 and 4.13.8. Users who cannot update to a patched version, should rotate their security keys and ensure their privacy to help migitgate the issue.
CVSS 8.1 · Высокий · EPSS 21,6% · В каталоге KEV · Есть исправление
- Опубликовано
- Обновлено
Стек: php
Затронутые продукты и версии
cms
- Версии
- >= 5.0.0-RC1, < 5.5.5: Затронуто
- >= 4.0.0-RC1, < 4.13.8: Затронуто
Нет опубликованного исправления
craftcms/cms Packagist
- Версии
- 5.0.0
- 5.0.0-RC1
- 5.0.1
- 5.0.2
- 5.0.3
- 5.0.4
- 5.0.5
- 5.0.6
- 5.1.0
- 5.1.1
- 5.1.10
- 5.1.2
- 5.1.3
- 5.1.4
- 5.1.5
- 5.1.6
- 5.1.7
- 5.1.8
- 5.1.9
- 5.2.0
- 5.2.0-beta.1
- 5.2.0-beta.2
- 5.2.0-beta.3
- 5.2.0-beta.4
- 5.2.0-beta.5
- 5.2.0-beta.6
- 5.2.1
- 5.2.10
- 5.2.2
- 5.2.3
- 5.2.4
- 5.2.4.1
- 5.2.5
- 5.2.6
- 5.2.7
- 5.2.8
- 5.2.9
- 5.3.0
- 5.3.0-beta.1
- 5.3.0-beta.2
- 5.3.0.1
- 5.3.0.2
- 5.3.0.3
- 5.3.1
- 5.3.2
- 5.3.3
- 5.3.4
- 5.3.5
- 5.3.6
- 5.4.0
- 5.4.0.1
- 5.4.1
- 5.4.10
- 5.4.10.1
- 5.4.2
- 5.4.3
- 5.4.4
- 5.4.5
- 5.4.5.1
- 5.4.6
- 5.4.7
- 5.4.7.1
- 5.4.8
- 5.4.9
- 5.5.0
- 5.5.0.1
- 5.5.1
- 5.5.1.1
- 5.5.2
- 5.5.3
- 5.5.4
- 5.5.5
- 5.5.6
- 5.5.6.1
- 5.5.7
- Затронутые диапазоны версий
- ECOSYSTEM: ≥ 5.0.0-RC1, < 5.5.8
Обновитесь до 5.5.8
craftcms/cms Packagist
- Версии
- 4.0.0
- 4.0.0-RC1
- 4.0.0-RC2
- 4.0.0-RC3
- 4.0.0.1
- 4.0.1
- 4.0.2
- 4.0.3
- 4.0.4
- 4.0.5
- 4.0.5.1
- 4.0.5.2
- 4.0.6
- 4.1.0
- 4.1.0.1
- 4.1.0.2
- 4.1.1
- 4.1.2
- 4.1.3
- 4.1.4
- 4.1.4.1
- 4.10.0
- 4.10.0-beta.1
- 4.10.0-beta.2
- 4.10.1
- 4.10.2
- 4.10.3
- 4.10.4
- 4.10.5
- 4.10.6
- 4.10.7
- 4.10.8
- 4.11.0
- 4.11.0.1
- 4.11.0.2
- 4.11.1
- 4.11.2
- 4.11.3
- 4.11.4
- 4.11.5
- 4.12.0
- 4.12.1
- 4.12.2
- 4.12.3
- 4.12.4
- 4.12.4.1
- 4.12.5
- 4.12.6
- 4.12.6.1
- 4.12.7
- 4.12.8
- 4.12.9
- 4.13.0
- 4.13.1
- 4.13.1.1
- 4.13.2
- 4.13.3
- 4.13.4
- 4.13.5
- 4.13.6
- 4.13.7
- 4.2.0
- 4.2.0.1
- 4.2.0.2
- 4.2.1
- 4.2.1.1
- 4.2.2
- 4.2.3
- 4.2.4
- 4.2.5
- 4.2.5.1
- 4.2.5.2
- 4.2.6
- 4.2.7
- 4.2.8
- 4.3.0
- 4.3.1
- 4.3.10
- 4.3.11
- 4.3.2
- 4.3.2.1
- 4.3.3
- 4.3.4
- 4.3.5
- 4.3.6
- 4.3.6.1
- 4.3.7
- 4.3.7.1
- 4.3.8
- 4.3.8.1
- 4.3.8.2
- 4.3.9
- 4.4.0
- 4.4.0-beta.1
- 4.4.0-beta.2
- 4.4.0-beta.3
- 4.4.0-beta.4
- 4.4.0-beta.5
- 4.4.0-beta.6
- 4.4.0-beta.7
- 4.4.1
- 4.4.10
- 4.4.10.1
- 4.4.11
- 4.4.12
- 4.4.13
- 4.4.14
- 4.4.15
- 4.4.16
- 4.4.16.1
- 4.4.17
- 4.4.2
- 4.4.3
- 4.4.4
- 4.4.5
- 4.4.6
- 4.4.6.1
- 4.4.7
- 4.4.7.1
- 4.4.8
- 4.4.9
- 4.5.0
- 4.5.0-beta.1
- 4.5.0-beta.2
- 4.5.1
- 4.5.10
- 4.5.11
- 4.5.11.1
- 4.5.12
- 4.5.13
- 4.5.14
- 4.5.15
- 4.5.2
- 4.5.3
- 4.5.4
- 4.5.5
- 4.5.6
- 4.5.6.1
- 4.5.7
- 4.5.8
- 4.5.9
- 4.6.0
- 4.6.0-RC1
- 4.6.1
- 4.7.0
- 4.7.1
- 4.7.2
- 4.7.2.1
- 4.7.3
- 4.7.4
- 4.8.0
- 4.8.1
- 4.8.10
- 4.8.11
- 4.8.2
- 4.8.3
- 4.8.4
- 4.8.5
- 4.8.6
- 4.8.7
- 4.8.8
- 4.8.9
- 4.9.0
- 4.9.1
- 4.9.2
- 4.9.3
- 4.9.4
- 4.9.5
- 4.9.6
- 4.9.7
- Затронутые диапазоны версий
- ECOSYSTEM: ≥ 4.0.0-RC1, < 4.13.8
Обновитесь до 4.13.8
Первоисточники
- https://github.com/craftcms/cms/security/advisories/GHSA-x684-96hh-833x
- https://github.com/craftcms/cms/commit/e59e22b30c9dd39e5e2c7fe02c147bcbd004e603
- https://craftcms.com/knowledge-base/securing-craft#keep-your-secrets-secret
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2025-23209
- https://nvd.nist.gov/vuln/detail/CVE-2025-23209