p PatchFirst

CVE-2025-24791

CVE-2025-24791 · snowflake-connector-nodejs has incorrect validation of temporary credential cache file permissions

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

snowflake-connector-nodejs is a NodeJS driver for Snowflake. Snowflake discovered and remediated a vulnerability in the Snowflake NodeJS Driver. File permissions checks of the temporary credential cache could be bypassed by an attacker with write access to the local cache directory. This vulnerability affects versions 1.12.0 through 2.0.1 on Linux. Snowflake fixed the issue in version 2.0.2.

CVSS 4.4 · Средний · EPSS 0,1% · Есть исправление

Опубликовано
Обновлено

Стек: node

Затронутые продукты и версии

  • snowflake-connector-nodejs

    Версии
    • >= 1.12.0, < 2.0.2: Затронуто

    Нет опубликованного исправления

  • snowflake-sdk npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 1.12.0, < 2.0.2

    Обновитесь до 2.0.2

Первоисточники

Проверьте свой сервер →