p PatchFirst

CVE-2025-24887

CVE-2025-24887 · OpenCTI bypass of protected attribute update

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

OpenCTI is an open-source cyber threat intelligence platform. In versions starting from 6.4.8 to before 6.4.10, the allow/deny lists can be bypassed, allowing a user to change attributes that are intended to be unmodifiable by the user. It is possible to toggle the `external` flag on/off and change the own token value for a user. It is also possible to edit attributes that are not in the allow list, such as `otp_qr` and `otp_activated`. If external users exist in the OpenCTI setup and the information about these users identities is sensitive, the above vulnerabilities can be used to enumerate existing user accounts as a standard low privileged user. This issue has been patched in version 6.4.10.

CVSS 6.3 · Средний · EPSS 0,3% · Есть исправление

Опубликовано
Обновлено

Стек: python

Затронутые продукты и версии

  • opencti

    Версии
    • >= 6.4.8, < 6.4.10: Затронуто

    Нет опубликованного исправления

  • pycti PyPI

    Версии
    • 6.4.10
    • 6.4.9
    Затронутые диапазоны версий
    • ECOSYSTEM: ≥ 6.4.9, < 6.4.11

    Обновитесь до 6.4.11

Первоисточники

Проверьте свой сервер →