CVE-2025-26619
CVE-2025-26619 · Vega Cross-Site Scripting (XSS) via event filter when not using CSP mode `expressionInterpeter`
CVSS 5.3 · Средний · EPSS 0,4% · Есть исправление
Затронуты ли вы?
- vegaНет опубликованного исправления
- vega.js Debian 12Нет опубликованного исправления
- vega.js Debian 13Нет опубликованного исправления
- vega.js Debian 14Обновитесь до 5.33.1+ds+~cs5.3.0-1
- и ещё 6
Как узнать установленную версию:
dpkg-query -W -f='${source:Package} ${binary:Package} ${Version}\n' | awk '$1=="vega.js"'Бесплатная проверка покажет рейтинг сервера и подсветит, требует ли внимания vega и остальные программы. Без регистрации; имена серверов и IP-адреса не отправляются. Номера CVE, версии исправлений и рекомендации — в платном мониторинге.
curl -fsSL https://ru.patchfirst.dev/check.sh | shЗдесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
Vega is a visualization grammar, a declarative format for creating, saving, and sharing interactive visualization designs. In `vega` 5.30.0 and lower and in `vega-functions` 5.15.0 and lower , it was possible to call JavaScript functions from the Vega expression language that were not meant to be supported. The issue is patched in `vega` `5.31.0` and `vega-functions` `5.16.0`. Some workarounds are available. Run `vega` without `vega.expressionInterpreter`. This mode is not the default as it is slower. Alternatively, using the interpreter described in CSP safe mode (Content Security Policy) prevents arbitrary Javascript from running, so users of this mode are not affected by this vulnerability.
- Опубликовано
- Обновлено
Затронутые продукты и версии
vega
- Версии
- < 5.31.0: Затронуто
Нет опубликованного исправления
vega.js Debian 12
- Версии
- 5.22.1+ds+~3.1.0-4
- 5.25.0+ds+~cs5.3.0-1
- 5.25.0+ds+~cs5.3.0-2
- 5.25.0+ds+~cs5.3.0-3
- 5.25.0+ds+~cs5.3.0-4
- 5.25.0+ds+~cs5.3.0-5
Все версии (13)
- 5.28.0+ds+~cs5.3.0-1
- 5.28.0+ds+~cs5.3.0-2
- 5.28.0+ds+~cs5.3.0-3
- 5.33.1+ds+~cs5.3.0-1
- 5.33.1+ds+~cs5.3.0-2
- 5.33.1+ds+~cs5.3.0-3
- 5.33.1+ds+~cs5.3.0-4
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
vega.js Debian 13
- Версии
- 5.28.0+ds+~cs5.3.0-1
- 5.28.0+ds+~cs5.3.0-2
- 5.28.0+ds+~cs5.3.0-3
- 5.33.1+ds+~cs5.3.0-1
- 5.33.1+ds+~cs5.3.0-2
- 5.33.1+ds+~cs5.3.0-3
Все версии (7)
- 5.33.1+ds+~cs5.3.0-4
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
vega.js Debian 14
- Версии
- 5.28.0+ds+~cs5.3.0-1
- 5.28.0+ds+~cs5.3.0-2
- 5.28.0+ds+~cs5.3.0-3
- Затронутые диапазоны версий
- ECOSYSTEM: < 5.33.1+ds+~cs5.3.0-1
Обновитесь до 5.33.1+ds+~cs5.3.0-1
vega npm
- Затронутые диапазоны версий
- SEMVER: < 5.31.0
Обновитесь до 5.31.0
vega-functions npm
- Затронутые диапазоны версий
- SEMVER: < 5.16.0
Обновитесь до 5.16.0
vega.js Ubuntu 24.04 LTS
- Версии
- 5.25.0+ds+~cs5.3.0-2
- 5.25.0+ds+~cs5.3.0-5
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
vega.js Ubuntu 25.10
- Версии
- 5.28.0+ds+~cs5.3.0-1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
vega.js Ubuntu 26.10
- Версии
- 5.28.0+ds+~cs5.3.0-2
- 5.33.1+ds+~cs5.3.0-4
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
vega.js Ubuntu 26.04 LTS
- Версии
- 5.28.0+ds+~cs5.3.0-1
- 5.28.0+ds+~cs5.3.0-2
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления