CVE-2025-26623
CVE-2025-26623 · Use After Free in Exiv2
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
Exiv2 is a C++ library and a command-line utility to read, write, delete and modify Exif, IPTC, XMP and ICC image metadata. A heap buffer overflow was found in Exiv2 versions v0.28.0 to v0.28.4. Versions prior to v0.28.0, such as v0.27.7, are **not** affected. Exiv2 is a command-line utility and C++ library for reading, writing, deleting, and modifying the metadata of image files. The heap overflow is triggered when Exiv2 is used to write metadata into a crafted image file. An attacker could potentially exploit the vulnerability to gain code execution, if they can trick the victim into running Exiv2 on a crafted image file. Note that this bug is only triggered when writing the metadata, which is a less frequently used Exiv2 operation than reading the metadata. For example, to trigger the bug in the Exiv2 command-line application, you need to add an extra command-line argument such as `fixiso`. The bug is fixed in version v0.28.5. Users are advised to upgrade. There are no known workarounds for this vulnerability.
CVSS 5.3 · Средний · EPSS 0,9% · Есть исправление
- Опубликовано
- Обновлено
Затронутые продукты и версии
exiv2
- Версии
- >= 0.28.0, < 0.28.5: Затронуто
Нет опубликованного исправления
exiv2 Debian:13
- Затронутые диапазоны версий
- ECOSYSTEM: < 0.28.4+dfsg-2
Обновитесь до 0.28.4+dfsg-2
exiv2 Debian:14
- Затронутые диапазоны версий
- ECOSYSTEM: < 0.28.4+dfsg-2
Обновитесь до 0.28.4+dfsg-2
exiv2 PyPI
- Затронутые диапазоны версий
- ECOSYSTEM: ≥ 0.28.0, < 0.28.5
Обновитесь до 0.28.5