CVE-2025-27613
CVE-2025-27613 · Gitk can create and truncate files in the user's home directory
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
Gitk is a Tcl/Tk based Git history browser. Starting with 1.7.0, when a user clones an untrusted repository and runs gitk without additional command arguments, files for which the user has write permission can be created and truncated. The option Support per-file encoding must have been enabled before in Gitk's Preferences. This option is disabled by default. The same happens when Show origin of this line is used in the main window (regardless of whether Support per-file encoding is enabled or not). This vulnerability is fixed in 2.43.7, 2.44.4, 2.45.4, 2.46.4, 2.47.3, 2.48.2, 2.49.1, and 2.50.1.
CVSS 3.6 · Низкий · EPSS 0,6% · Есть исправление
- Опубликовано
- Обновлено
Стек: system
Затронутые продукты и версии
gitk
- Версии
- >= 1.7.0, < 2.43.7: Затронуто
- >= 2.44.0, < 2.44.4: Затронуто
- >= 2.45.0, < 2.45.4: Затронуто
- >= 2.46.0, < 2.46.4: Затронуто
- >= 2.47.0, < 2.47.3: Затронуто
- >= 2.48.0, < 2.48.2: Затронуто
- >= 2.49.0, < 2.49.1: Затронуто
- >= 2.50.0, < 2.50.1: Затронуто
Нет опубликованного исправления
git Debian:12
- Версии
- 1:2.39.2+next.20230215-1
- 1:2.39.2-1.1
- 1:2.39.5-0+deb12u1
- 1:2.39.5-0+deb12u2
- Затронутые диапазоны версий
- ECOSYSTEM: < 1:2.39.5-0+deb12u3
Обновитесь до 1:2.39.5-0+deb12u3
git Debian:13
- Версии
- 1:2.47.2-0.2
- Затронутые диапазоны версий
- ECOSYSTEM: < 1:2.47.3-0+deb13u1
Обновитесь до 1:2.47.3-0+deb13u1
git Debian:14
- Версии
- 1:2.47.2-0.2
- 1:2.48.0~rc1+next.20250101-1
- 1:2.49.0+next.20250314-1
- 1:2.49.0-1
- 1:2.49.0-2
- 1:2.49.0-3
- 1:2.50.0+next.20250615-1
- 1:2.50.0-1
- 1:2.50.0~rc0+next.20250528-1
- Затронутые диапазоны версий
- ECOSYSTEM: < 1:2.50.1-0.1
Обновитесь до 1:2.50.1-0.1
git Ubuntu:Pro:16.04:LTS
- Версии
- 1:2.5.0-1
- 1:2.6.2-1
- 1:2.6.3-1
- 1:2.6.4-1
- 1:2.7.0~rc3-1
- 1:2.7.0-1
- 1:2.7.3-0ubuntu1
- 1:2.7.4-0ubuntu1
- 1:2.7.4-0ubuntu1.1
- 1:2.7.4-0ubuntu1.2
- 1:2.7.4-0ubuntu1.3
- 1:2.7.4-0ubuntu1.4
- 1:2.7.4-0ubuntu1.5
- 1:2.7.4-0ubuntu1.6
- 1:2.7.4-0ubuntu1.7
- 1:2.7.4-0ubuntu1.8
- 1:2.7.4-0ubuntu1.9
- 1:2.7.4-0ubuntu1.10
- 1:2.7.4-0ubuntu1.10+esm1
- 1:2.7.4-0ubuntu1.10+esm3
- 1:2.7.4-0ubuntu1.10+esm4
- 1:2.7.4-0ubuntu1.10+esm5
- 1:2.7.4-0ubuntu1.10+esm6
- 1:2.7.4-0ubuntu1.10+esm7
- 1:2.7.4-0ubuntu1.10+esm8
- 1:2.7.4-0ubuntu1.10+esm9
- 1:2.7.4-0ubuntu1.10+esm10
- Затронутые диапазоны версий
- ECOSYSTEM: < 1:2.7.4-0ubuntu1.10+esm11
Обновитесь до 1:2.7.4-0ubuntu1.10+esm11
git Ubuntu:Pro:18.04:LTS
- Версии
- 1:2.14.1-1ubuntu4
- 1:2.15.1-1ubuntu2
- 1:2.17.0-1ubuntu1
- 1:2.17.1-1ubuntu0.1
- 1:2.17.1-1ubuntu0.3
- 1:2.17.1-1ubuntu0.4
- 1:2.17.1-1ubuntu0.5
- 1:2.17.1-1ubuntu0.6
- 1:2.17.1-1ubuntu0.7
- 1:2.17.1-1ubuntu0.8
- 1:2.17.1-1ubuntu0.9
- 1:2.17.1-1ubuntu0.10
- 1:2.17.1-1ubuntu0.11
- 1:2.17.1-1ubuntu0.12
- 1:2.17.1-1ubuntu0.13
- 1:2.17.1-1ubuntu0.14
- 1:2.17.1-1ubuntu0.15
- 1:2.17.1-1ubuntu0.16
- 1:2.17.1-1ubuntu0.17
- 1:2.17.1-1ubuntu0.18
- 1:2.17.1-1ubuntu0.18+esm1
- 1:2.17.1-1ubuntu0.18+esm2
- 1:2.17.1-1ubuntu0.18+esm3
- Затронутые диапазоны версий
- ECOSYSTEM: < 1:2.17.1-1ubuntu0.18+esm4
Обновитесь до 1:2.17.1-1ubuntu0.18+esm4
git Ubuntu:Pro:20.04:LTS
- Версии
- 1:2.20.1-2ubuntu1
- 1:2.24.0-1ubuntu1
- 1:2.24.0-1ubuntu2
- 1:2.25.0-1ubuntu1
- 1:2.25.1-1ubuntu1
- 1:2.25.1-1ubuntu2
- 1:2.25.1-1ubuntu3
- 1:2.25.1-1ubuntu3.1
- 1:2.25.1-1ubuntu3.2
- 1:2.25.1-1ubuntu3.3
- 1:2.25.1-1ubuntu3.4
- 1:2.25.1-1ubuntu3.5
- 1:2.25.1-1ubuntu3.6
- 1:2.25.1-1ubuntu3.7
- 1:2.25.1-1ubuntu3.8
- 1:2.25.1-1ubuntu3.10
- 1:2.25.1-1ubuntu3.11
- 1:2.25.1-1ubuntu3.12
- 1:2.25.1-1ubuntu3.13
- 1:2.25.1-1ubuntu3.14
- 1:2.25.1-1ubuntu3.14+esm1
- 1:2.25.1-1ubuntu3.14+esm2
- Затронутые диапазоны версий
- ECOSYSTEM: < 1:2.25.1-1ubuntu3.14+esm3
Обновитесь до 1:2.25.1-1ubuntu3.14+esm3
git Ubuntu:22.04:LTS
- Версии
- 1:2.32.0-1ubuntu1
- 1:2.33.1-1ubuntu1
- 1:2.34.1-1ubuntu1
- 1:2.34.1-1ubuntu1.1
- 1:2.34.1-1ubuntu1.2
- 1:2.34.1-1ubuntu1.4
- 1:2.34.1-1ubuntu1.5
- 1:2.34.1-1ubuntu1.6
- 1:2.34.1-1ubuntu1.8
- 1:2.34.1-1ubuntu1.9
- 1:2.34.1-1ubuntu1.10
- 1:2.34.1-1ubuntu1.11
- 1:2.34.1-1ubuntu1.12
- 1:2.34.1-1ubuntu1.13
- 1:2.34.1-1ubuntu1.14
- Затронутые диапазоны версий
- ECOSYSTEM: < 1:2.34.1-1ubuntu1.15
Обновитесь до 1:2.34.1-1ubuntu1.15
git Ubuntu:24.04:LTS
- Версии
- 1:2.40.1-1ubuntu1
- 1:2.43.0-1ubuntu1
- 1:2.43.0-1ubuntu5
- 1:2.43.0-1ubuntu6
- 1:2.43.0-1ubuntu7
- 1:2.43.0-1ubuntu7.1
- 1:2.43.0-1ubuntu7.2
- Затронутые диапазоны версий
- ECOSYSTEM: < 1:2.43.0-1ubuntu7.3
Обновитесь до 1:2.43.0-1ubuntu7.3
Первоисточники
- https://github.com/j6t/gitk/security/advisories/GHSA-f3cw-xrj3-wr2v
- https://github.com/j6t/gitk/compare/465f03869ae11acd04abfa1b83c67879c867410c..026c397d911cde55924d7eb1311d0fd6e2e105d5
- https://github.com/j6t/gitk/compare/7dd272eca153058da2e8d5b9960bbbf0b4f0cbaa..67a128b91e25978a15f9f7e194d81b441d603652
- https://lists.debian.org/debian-lts-announce/2025/10/msg00003.html
- http://www.openwall.com/lists/oss-security/2025/07/08/4
- https://nvd.nist.gov/vuln/detail/CVE-2025-27613