CVE-2025-29788
CVE-2025-29788 · Sylius PayPal Plugin Payment Amount Manipulation Vulnerability
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
The Syliud PayPal Plugin is the Sylius Core Team’s plugin for the PayPal Commerce Platform. A vulnerability in versions prior to 1.6.1, 1.7.1, and 2.0.1 allows users to manipulate the final payment amount processed by PayPal. If a user modifies the item quantity in their shopping cart after initiating the PayPal Express Checkout process, PayPal will not receive the updated total amount. As a result, PayPal captures only the initially transmitted amount, while Sylius incorrectly considers the order fully paid based on the modified total. This flaw can be exploited both accidentally and intentionally, potentially enabling fraud by allowing customers to pay less than the actual order value. Attackers can intentionally pay less than the actual total order amount, business owners may suffer financial losses due to underpaid orders, and integrity of payment processing is compromised. The issue is fixed in versions 1.6.1, 1.7.1, 2.0.1, and above. To resolve the problem in the end application without updating to the newest patches, there is a need to overwrite `ProcessPayPalOrderAction`, `CompletePayPalOrderFromPaymentPageAction`, and `CaptureAction` with modified logic.
CVSS 6.5 · Средний · EPSS 0,5% · Есть исправление
- Опубликовано
- Обновлено
Стек: php
Затронутые продукты и версии
paypalplugin
- Версии
- < 1.6.1: Затронуто
- >= 1.7, < 1.7.1: Затронуто
- >= 2.0, < 2.0.1: Затронуто
Нет опубликованного исправления
sylius/paypal-plugin Packagist
- Версии
- v0.1.0
- v0.1.1
- v0.2.0
- v0.2.1
- v0.3.0
- v0.3.1
- v1.0.0
- v1.0.0-BETA.1
- v1.0.0-BETA.2
- v1.0.0-BETA.3
- v1.0.0-BETA.4
- v1.0.0-RC.1
- v1.0.0-RC.2
- v1.0.1
- v1.0.2
- v1.0.3
- v1.0.4
- v1.1.0
- v1.1.1
- v1.2.0
- v1.2.1
- v1.2.2
- v1.2.3
- v1.2.4
- v1.3.0
- v1.3.1
- v1.3.2
- v1.4.0
- v1.4.1
- v1.4.2
- v1.5.0
- v1.5.1
- v1.5.2
- v1.5.3
- v1.6.0
- Затронутые диапазоны версий
- ECOSYSTEM: < 1.6.1
Обновитесь до 1.6.1
sylius/paypal-plugin Packagist
- Версии
- v1.7.0
- Затронутые диапазоны версий
- ECOSYSTEM: ≥ 1.7.0, < 1.7.1
Обновитесь до 1.7.1
sylius/paypal-plugin Packagist
- Версии
- v2.0.0
- Затронутые диапазоны версий
- ECOSYSTEM: ≥ 2.0.0, < 2.0.1
Обновитесь до 2.0.1
Первоисточники
- https://github.com/Sylius/PayPalPlugin/security/advisories/GHSA-pqq3-q84h-pj6x
- https://github.com/Sylius/PayPalPlugin/commit/31e71b0457e5d887a6c19f8cfabb8b16125ec406
- https://github.com/Sylius/PayPalPlugin/commit/8a81258f965b7860d4bccb52942e4c5b53e6774d
- https://github.com/Sylius/PayPalPlugin/releases/tag/v1.6.1
- https://github.com/Sylius/PayPalPlugin/releases/tag/v1.7.1
- https://github.com/Sylius/PayPalPlugin/releases/tag/v2.0.1
- https://nvd.nist.gov/vuln/detail/CVE-2025-29788