p PatchFirst

CVE-2025-29927

CVE-2025-29927 · Authorization Bypass in Next.js Middleware

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

Next.js is a React framework for building full-stack web applications. Starting in version 1.11.4 and prior to versions 12.3.5, 13.5.9, 14.2.25, and 15.2.3, it is possible to bypass authorization checks within a Next.js application, if the authorization check occurs in middleware. If patching to a safe version is infeasible, it is recommend that you prevent external user requests which contain the x-middleware-subrequest header from reaching your Next.js application. This vulnerability is fixed in 12.3.5, 13.5.9, 14.2.25, and 15.2.3.

CVSS 9.1 · Критический · EPSS 99,2% · Публичный эксплойт · Есть исправление

Опубликовано
Обновлено

Стек: node

Затронутые продукты и версии

  • next.js

    Версии
    • >= 11.1.4, < 12.3.5: Затронуто
    • >= 14.0.0, < 14.2.25: Затронуто
    • >= 15.0.0, < 15.2.3: Затронуто
    • >= 13.0.0, < 13.5.9: Затронуто

    Нет опубликованного исправления

  • next npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 13.0.0, < 13.5.9

    Обновитесь до 13.5.9

  • next npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 14.0.0, < 14.2.25

    Обновитесь до 14.2.25

  • next npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 15.0.0, < 15.2.3

    Обновитесь до 15.2.3

  • next npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 12.0.0, < 12.3.5

    Обновитесь до 12.3.5

Первоисточники

Проверьте свой сервер →