CVE-2025-30193
CVE-2025-30193 · Denial of service via crafted TCP exchange
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
In some circumstances, when DNSdist is configured to allow an unlimited number of queries on a single, incoming TCP connection from a client, an attacker can cause a denial of service by crafting a TCP exchange that triggers an exhaustion of the stack and a crash of DNSdist, causing a denial of service. The remedy is: upgrade to the patched 1.9.10 version. A workaround is to restrict the maximum number of queries on incoming TCP connections to a safe value, like 50, via the setMaxTCPQueriesPerConnection setting. We would like to thank Renaud Allard for bringing this issue to our attention.
CVSS 7.5 · Высокий · EPSS 0,6% · Есть исправление
- Опубликовано
- Обновлено
Стек: system
Затронутые продукты и версии
dnsdist
- Версии
- 1.9.10: Не затронуто (semver)
Нет опубликованного исправления
dnsdist Debian:12
- Версии
- 1.7.3-2
- 1.8.0-1
- 1.8.1-1
- 1.8.2-1
- 1.8.2-2
- 1.8.2-3
- 1.8.3-1
- 1.8.3-2
- 1.8.3-3
- 1.9.10-1
- 1.9.3-1
- 1.9.4-1
- 1.9.5-1
- 1.9.6-1
- 1.9.8-1
- 1.9.9-1
- 2.0.0-1
- 2.0.0-2
- 2.0.0-3
- 2.0.0-4
- 2.0.0-5
- 2.0.0-6
- 2.0.0~rc1-1
- 2.0.0~rc1-2
- 2.0.0~rc2-1
- 2.0.1-1
- 2.0.2-1
- 2.0.3-1
- 2.0.4-1
- 2.0.5-1
- 2.0.5-2
- 2.0.5-3
- 2.0.6-1
- 2.1.0-1
- 2.1.0-2
- 2.1.1-1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
dnsdist Debian:13
- Затронутые диапазоны версий
- ECOSYSTEM: < 1.9.10-1
Обновитесь до 1.9.10-1
dnsdist Debian:14
- Затронутые диапазоны версий
- ECOSYSTEM: < 1.9.10-1
Обновитесь до 1.9.10-1
dnsdist Ubuntu:Pro:22.04:LTS
- Версии
- 1.5.1-3build2
- 1.6.1-1build1
- 1.6.1-1ubuntu0.1~esm1
- Затронутые диапазоны версий
- ECOSYSTEM: < 1.6.1-1ubuntu0.1~esm2
Обновитесь до 1.6.1-1ubuntu0.1~esm2
dnsdist Ubuntu:Pro:24.04:LTS
- Версии
- 1.8.0-1
- 1.8.2-1
- 1.8.2-2
- 1.8.2-3
- 1.8.3-1
- 1.8.3-2
- 1.8.3-2build1
- 1.8.3-2build2
- Затронутые диапазоны версий
- ECOSYSTEM: < 1.8.3-2ubuntu0.1~esm1
Обновитесь до 1.8.3-2ubuntu0.1~esm1