CVE-2025-30218
CVE-2025-30218 · Next.js may leak x-middleware-subrequest-id to external hosts
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
Next.js is a React framework for building full-stack web applications. To mitigate CVE-2025-29927, Next.js validated the x-middleware-subrequest-id which persisted across multiple incoming requests. However, this subrequest ID is sent to all requests, even if the destination is not the same host as the Next.js application. Initiating a fetch request to a third-party within Middleware will send the x-middleware-subrequest-id to that third party. This vulnerability is fixed in 12.3.6, 13.5.10, 14.2.26, and 15.2.4.
CVSS 1.7 · Низкий · EPSS 0,4% · Есть исправление
- Опубликовано
- Обновлено
Стек: node
Затронутые продукты и версии
next.js
- Версии
- = 12.3.5: Затронуто
- = 13.5.9: Затронуто
- = 14.2.25: Затронуто
- = 15.2.3: Затронуто
Нет опубликованного исправления
next npm
- Версии
- 12.3.5
- Затронутые диапазоны версий
- SEMVER: ≥ 12.3.5, < 12.3.6
Обновитесь до 12.3.6
next npm
- Версии
- 13.5.9
- Затронутые диапазоны версий
- SEMVER: ≥ 13.5.9, < 13.5.10
Обновитесь до 13.5.10
next npm
- Версии
- 14.2.25
- Затронутые диапазоны версий
- SEMVER: ≥ 14.2.25, < 14.2.26
Обновитесь до 14.2.26
next npm
- Версии
- 15.2.3
- Затронутые диапазоны версий
- SEMVER: ≥ 15.2.3, < 15.2.4
Обновитесь до 15.2.4