CVE-2025-31125
CVE-2025-31125 · Vite has a `server.fs.deny` bypassed for `inline` and `raw` with `?import` query
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
Vite is a frontend tooling framework for javascript. Vite exposes content of non-allowed files using ?inline&import or ?raw?import. Only apps explicitly exposing the Vite dev server to the network (using --host or server.host config option) are affected. This vulnerability is fixed in 6.2.4, 6.1.3, 6.0.13, 5.4.16, and 4.5.11.
CVSS 5.3 · Средний · EPSS 65,8% · В каталоге KEV · Публичный эксплойт · Есть исправление
- Опубликовано
- Обновлено
Стек: node
Затронутые продукты и версии
vite
- Версии
- >= 6.2.0, < 6.2.4: Затронуто
- >= 6.1.0, < 6.1.3: Затронуто
- >= 6.0.0, < 6.0.13: Затронуто
- >= 5.0.0, < 5.4.16: Затронуто
- < 4.5.11: Затронуто
Нет опубликованного исправления
vite npm
- Затронутые диапазоны версий
- SEMVER: ≥ 6.2.0, < 6.2.4
Обновитесь до 6.2.4
vite npm
- Затронутые диапазоны версий
- SEMVER: ≥ 6.1.0, < 6.1.3
Обновитесь до 6.1.3
vite npm
- Затронутые диапазоны версий
- SEMVER: ≥ 6.0.0, < 6.0.13
Обновитесь до 6.0.13
vite npm
- Затронутые диапазоны версий
- SEMVER: ≥ 5.0.0, < 5.4.16
Обновитесь до 5.4.16
vite npm
- Затронутые диапазоны версий
- SEMVER: < 4.5.11
Обновитесь до 4.5.11