CVE-2025-32442
CVE-2025-32442 · Fastify vulnerable to invalid content-type parsing, which could lead to validation bypass
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
Fastify is a fast and low overhead web framework, for Node.js. In versions 5.0.0 to 5.3.0 as well as version 4.29.0, applications that specify different validation strategies for different content types have a possibility to bypass validation by providing a _slightly altered_ content type such as with different casing or altered whitespacing before `;`. This was patched in v5.3.1, but the initial patch did not cover all problems. This has been fully patched in v5.3.2 and v4.29.1. A workaround involves not specifying individual content types in the schema.
CVSS 7.5 · Высокий · EPSS 0,7% · Есть исправление
- Опубликовано
- Обновлено
Стек: node
Затронутые продукты и версии
fastify
- Версии
- >= 5.0.0, < 5.3.2: Затронуто
- = 4.29.0: Затронуто
Нет опубликованного исправления
fastify npm
- Затронутые диапазоны версий
- SEMVER: ≥ 5.3.2, < 5.8.5
Обновитесь до 5.8.5
fastify npm
- Затронутые диапазоны версий
- SEMVER: ≥ 5.0.0, < 5.3.2
Обновитесь до 5.3.2
fastify npm
- Версии
- 4.29.0
- Затронутые диапазоны версий
- SEMVER: ≥ 4.29.0, < 4.29.1
Обновитесь до 4.29.1
Первоисточники
- https://github.com/fastify/fastify/security/advisories/GHSA-mg2h-6x62-wpwc
- https://github.com/fastify/fastify/commit/436da4c06dfbbb8c24adee3a64de0c51e4f47418
- https://github.com/fastify/fastify/commit/f3d2bcb3963cd570a582e5d39aab01a9ae692fe4
- https://hackerone.com/reports/3087928
- https://nvd.nist.gov/vuln/detail/CVE-2025-32442