CVE-2025-46817
CVE-2025-46817 · Lua library commands may lead to integer overflow and potential RCE
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
Redis is an open source, in-memory database that persists on disk. Versions 8.2.1 and below allow an authenticated user to use a specially crafted Lua script to cause an integer overflow and potentially lead to remote code execution The problem exists in all versions of Redis with Lua scripting. This issue is fixed in version 8.2.2.
CVSS 7.0 · Высокий · EPSS 3,9% · Публичный эксплойт · Есть исправление
- Опубликовано
- Обновлено
Затронутые продукты и версии
redis
- Версии
- < 8.2.2: Затронуто
Нет опубликованного исправления
redict Debian:14
- Версии
- 7.3.0+ds-1
- 7.3.0+ds-2
- 7.3.0+ds-3
- 7.3.0+ds-3~bpo12+1
- 7.3.1+ds-1
- 7.3.2+ds-1
- 7.3.2+ds-1~bpo12+1
- 7.3.5+ds-1
- 7.3.5+ds-1~bpo12+1
- 7.3.6+ds-1~bpo12+1
- 7.3.6+ds-1~bpo13+1
- Затронутые диапазоны версий
- ECOSYSTEM: < 7.3.6+ds-1
Обновитесь до 7.3.6+ds-1
redis Debian:12
- Версии
- 5:7.0.11-1
- 5:7.0.11-1+deb12u1
- 5:7.0.12-1
- 5:7.0.12-2
- 5:7.0.13-1
- 5:7.0.13-2
- 5:7.0.14-1
- 5:7.0.14-2
- 5:7.0.15-1~deb12u1
- 5:7.0.15-1~deb12u2
- 5:7.0.15-1~deb12u3
- 5:7.0.15-1~deb12u4
- 5:7.0.15-1~deb12u5
- Затронутые диапазоны версий
- ECOSYSTEM: < 5:7.0.15-1~deb12u6
Обновитесь до 5:7.0.15-1~deb12u6
redis Debian:13
- Версии
- 5:8.0.2-3
- Затронутые диапазоны версий
- ECOSYSTEM: < 5:8.0.2-3+deb13u1
Обновитесь до 5:8.0.2-3+deb13u1
redis Debian:14
- Версии
- 5:8.0.2-3
- Затронутые диапазоны версий
- ECOSYSTEM: < 5:8.0.4-1
Обновитесь до 5:8.0.4-1
valkey Debian:13
- Версии
- 8.1.1+dfsg1-3
- Затронутые диапазоны версий
- ECOSYSTEM: < 8.1.1+dfsg1-3+deb13u1
Обновитесь до 8.1.1+dfsg1-3+deb13u1
valkey Debian:14
- Версии
- 8.1.1+dfsg1-3
- Затронутые диапазоны версий
- ECOSYSTEM: < 8.1.4+dfsg1-1
Обновитесь до 8.1.4+dfsg1-1
valkey Ubuntu:24.04:LTS
- Версии
- 7.2.5+dfsg1-2ubuntu4~24.04.1
- 7.2.7+dfsg1-0ubuntu0.24.04.1
- 7.2.8+dfsg1-0ubuntu0.24.04.1
- 7.2.8+dfsg1-0ubuntu0.24.04.2
- 7.2.8+dfsg1-0ubuntu0.24.04.3
- 7.2.10+dfsg1-0ubuntu0.1
- 7.2.11+dfsg1-0ubuntu0.1
- Затронутые диапазоны версий
- ECOSYSTEM: < 7.2.11+dfsg1-0ubuntu0.2
Обновитесь до 7.2.11+dfsg1-0ubuntu0.2
redict Ubuntu:25.10
- Версии
- 7.3.2+ds-1
- 7.3.5+ds-1
- 7.3.5+ds-1ubuntu0.1
- 7.3.5+ds-1ubuntu0.2
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
valkey Ubuntu:25.10
- Версии
- 8.0.2+dfsg1-1ubuntu1
- 8.1.1+dfsg1-2ubuntu1
- 8.1.3+dfsg1-0ubuntu1
- 8.1.3+dfsg1-0ubuntu2
- 8.1.4+dfsg1-0ubuntu0.1
- Затронутые диапазоны версий
- ECOSYSTEM: < 8.1.4+dfsg1-0ubuntu0.2
Обновитесь до 8.1.4+dfsg1-0ubuntu0.2
redict Ubuntu:26.10
- Версии
- 7.3.6+ds-1
- 7.3.6+ds-2
- 7.3.6+ds-2build1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
redict Ubuntu:26.04:LTS
- Версии
- 7.3.5+ds-1
- 7.3.5+ds-1ubuntu0.1
- 7.3.6+ds-1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления