p PatchFirst

CVE-2025-47944

CVE-2025-47944 · Multer vulnerable to Denial of Service from maliciously crafted requests

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

Multer is a node.js middleware for handling `multipart/form-data`. A vulnerability that is present starting in version 1.4.4-lts.1 and prior to version 2.0.0 allows an attacker to trigger a Denial of Service (DoS) by sending a malformed multi-part upload request. This request causes an unhandled exception, leading to a crash of the process. Users should upgrade to version 2.0.0 to receive a patch. No known workarounds are available.

CVSS 7.5 · Высокий · EPSS 0,8% · Есть исправление

Опубликовано
Обновлено

Стек: node

Затронутые продукты и версии

  • multer

    Версии
    • >=1.4.4-lts.1, <2.0.0: Затронуто

    Нет опубликованного исправления

  • multer npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 1.4.4-lts.1, < 2.0.0

    Обновитесь до 2.0.0

Первоисточники

Проверьте свой сервер →