p PatchFirst

CVE-2025-48068

CVE-2025-48068 · Information exposure in Next.js dev server due to lack of origin verification

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

Next.js is a React framework for building full-stack web applications. In versions starting from 13.0 to before 14.2.30 and 15.0.0 to before 15.2.2, Next.js may have allowed limited source code exposure when the dev server was running with the App Router enabled. The vulnerability only affects local development environments and requires the user to visit a malicious webpage while npm run dev is active. This issue has been patched in versions 14.2.30 and 15.2.2.

CVSS 2.3 · Низкий · EPSS 0,2% · Есть исправление

Опубликовано
Обновлено

Стек: node

Затронутые продукты и версии

  • next.js

    Версии
    • >= 13.0, < 14.2.30: Затронуто
    • >= 15.0.0, < 15.2.2: Затронуто

    Нет опубликованного исправления

  • next npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 15.0.0, < 15.2.2

    Обновитесь до 15.2.2

  • next npm

    Затронутые диапазоны версий
    • ECOSYSTEM: ≥ 13.0, < 14.2.30

    Обновитесь до 14.2.30

Первоисточники

Проверьте свой сервер →