p PatchFirst

CVE-2025-48385

CVE-2025-48385 · Git alllows arbitrary file writes via bundle-uri parameter injection

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

Git is a fast, scalable, distributed revision control system with an unusually rich command set that provides both high-level operations and full access to internals. When cloning a repository Git knows to optionally fetch a bundle advertised by the remote server, which allows the server-side to offload parts of the clone to a CDN. The Git client does not perform sufficient validation of the advertised bundles, which allows the remote side to perform protocol injection. This protocol injection can cause the client to write the fetched bundle to a location controlled by the adversary. The fetched content is fully controlled by the server, which can in the worst case lead to arbitrary code execution. The use of bundle URIs is not enabled by default and can be controlled by the bundle.heuristic config option. Some cases of the vulnerability require that the adversary is in control of where a repository will be cloned to. This either requires social engineering or a recursive clone with submodules. These cases can thus be avoided by disabling recursive clones. This vulnerability is fixed in v2.43.7, v2.44.4, v2.45.4, v2.46.4, v2.47.3, v2.48.2, v2.49.1, and v2.50.1.

CVSS 8.6 · Высокий · EPSS 1,1% · Есть исправление

Опубликовано
Обновлено

Стек: system

Затронутые продукты и версии

  • git

    Версии
    • < 2.43.7: Затронуто
    • >= 2.44.0-rc0, < 2.44.4: Затронуто
    • >= 2.45.0-rc0, < 2.45.4: Затронуто
    • >= 2.46.0-rc0, < 2.46.4: Затронуто
    • >= 2.47.0-rc0, < 2.47.3: Затронуто
    • >= 2.48.0-rc0, < 2.48.2: Затронуто
    • >= 2.49.0-rc0, < 2.49.1: Затронуто
    • >= 2.50.0-rc0, < 2.50.1: Затронуто

    Нет опубликованного исправления

  • git Debian:12

    Версии
    • 1:2.39.2+next.20230215-1
    • 1:2.39.2-1.1
    • 1:2.39.5-0+deb12u1
    • 1:2.39.5-0+deb12u2
    Затронутые диапазоны версий
    • ECOSYSTEM: < 1:2.39.5-0+deb12u3

    Обновитесь до 1:2.39.5-0+deb12u3

  • git Debian:13

    Версии
    • 1:2.47.2-0.2
    Затронутые диапазоны версий
    • ECOSYSTEM: < 1:2.47.3-0+deb13u1

    Обновитесь до 1:2.47.3-0+deb13u1

  • git Debian:14

    Версии
    • 1:2.47.2-0.2
    • 1:2.48.0~rc1+next.20250101-1
    • 1:2.49.0+next.20250314-1
    • 1:2.49.0-1
    • 1:2.49.0-2
    • 1:2.49.0-3
    • 1:2.50.0+next.20250615-1
    • 1:2.50.0-1
    • 1:2.50.0~rc0+next.20250528-1
    Затронутые диапазоны версий
    • ECOSYSTEM: < 1:2.50.1-0.1

    Обновитесь до 1:2.50.1-0.1

  • git Ubuntu:24.04:LTS

    Версии
    • 1:2.40.1-1ubuntu1
    • 1:2.43.0-1ubuntu1
    • 1:2.43.0-1ubuntu5
    • 1:2.43.0-1ubuntu6
    • 1:2.43.0-1ubuntu7
    • 1:2.43.0-1ubuntu7.1
    • 1:2.43.0-1ubuntu7.2
    Затронутые диапазоны версий
    • ECOSYSTEM: < 1:2.43.0-1ubuntu7.3

    Обновитесь до 1:2.43.0-1ubuntu7.3

Первоисточники

Проверьте свой сервер →