CVE-2025-48387
CVE-2025-48387 · tar-fs has issue where extract can write outside the specified dir with a specific tarball
CVSS 8.7 · Высокий · EPSS 0,6% · Есть исправление
Затронуты ли вы?
- tar-fsНет опубликованного исправления
- node-tar-fs Debian 12Обновитесь до 2.1.3-0+deb12u1
- node-tar-fs Debian 13Обновитесь до 3.0.9+~cs2.0.4-1
- node-tar-fs Debian 14Обновитесь до 3.0.9+~cs2.0.4-1
- и ещё 3
Как узнать установленную версию:
dpkg-query -W -f='${source:Package} ${binary:Package} ${Version}\n' | awk '$1=="node-tar-fs"'Бесплатная проверка покажет рейтинг сервера и подсветит, требует ли внимания tar-fs и остальные программы. Без регистрации; имена серверов и IP-адреса не отправляются. Номера CVE, версии исправлений и рекомендации — в платном мониторинге.
curl -fsSL https://ru.patchfirst.dev/check.sh | shЗдесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
tar-fs provides filesystem bindings for tar-stream. Versions prior to 3.0.9, 2.1.3, and 1.16.5 have an issue where an extract can write outside the specified dir with a specific tarball. This has been patched in versions 3.0.9, 2.1.3, and 1.16.5. As a workaround, use the ignore option to ignore non files/directories.
- Опубликовано
- Обновлено
Затронутые продукты и версии
tar-fs
- Версии
- < 1.16.5: Затронуто
- >= 2.0.0, < 2.1.3: Затронуто
- >= 3.0.0, < 3.0.9: Затронуто
Нет опубликованного исправления
node-tar-fs Debian 12
- Версии
- 2.1.1-6
- Затронутые диапазоны версий
- ECOSYSTEM: < 2.1.3-0+deb12u1
Обновитесь до 2.1.3-0+deb12u1
node-tar-fs Debian 13
- Затронутые диапазоны версий
- ECOSYSTEM: < 3.0.9+~cs2.0.4-1
Обновитесь до 3.0.9+~cs2.0.4-1
node-tar-fs Debian 14
- Затронутые диапазоны версий
- ECOSYSTEM: < 3.0.9+~cs2.0.4-1
Обновитесь до 3.0.9+~cs2.0.4-1
tar-fs npm
- Затронутые диапазоны версий
- SEMVER: < 1.16.5
Обновитесь до 1.16.5
tar-fs npm
- Затронутые диапазоны версий
- SEMVER: ≥ 2.0.0, < 2.1.3
Обновитесь до 2.1.3
tar-fs npm
- Затронутые диапазоны версий
- SEMVER: ≥ 3.0.0, < 3.0.9
Обновитесь до 3.0.9
node-tar-fs Ubuntu Pro 22.04 LTS
- Версии
- 2.1.1-2
- 2.1.1-4
- 2.1.1-6
- Затронутые диапазоны версий
- ECOSYSTEM: < 2.1.1-6ubuntu0.22.04.1~esm1
Обновитесь до 2.1.1-6ubuntu0.22.04.1~esm1
node-tar-fs Ubuntu Pro 24.04 LTS
- Версии
- 2.1.1-6
- Затронутые диапазоны версий
- ECOSYSTEM: < 2.1.1-6ubuntu0.24.04.1~esm1
Обновитесь до 2.1.1-6ubuntu0.24.04.1~esm1
Первоисточники
- https://github.com/mafintosh/tar-fs/security/advisories/GHSA-8cj5-5rvv-wf4v
- https://github.com/google/security-research/security/advisories/GHSA-xrg4-qp5w-2c3w
- https://github.com/mafintosh/tar-fs/commit/647447b572bc135c41035e82ca7b894f02b17f0f
- https://lists.debian.org/debian-lts-announce/2025/06/msg00012.html
- https://nvd.nist.gov/vuln/detail/CVE-2025-48387